Time step too small Error in LT SPICE

Thread Starter

sunney

Joined Sep 3, 2015
9
Hi,

I know this issue has been discussed on so many threads, I have gone through most of them if not all and still didnt have any success.
I am using LM5017 switching regulator and the error I am getting is "Analysis: Time step too small; trouble with u2:u2_qb_nd" where u2 is LM5017 and u2_qb_nd is one net in spice model of LM5017. Please help.

Sunney
 

ebeowulf17

Joined Aug 12, 2014
3,274
Please upload your schematic, preferably as a reasonably sized image, so we can see what you've got going.

As a general rule, no schematic = no help.
 

ebeowulf17

Joined Aug 12, 2014
3,274
Thanks for the quick reply.

Unfortunately, I won't be at a computer where I can view Spice files much, if at all, today. If you upload an image (JPG, PNG, etc.) of the schematic, I'd be happy to look at that and see what I can find.

Of course, if the problem really is within the Spice model of a component, that won't help, but sometimes it's something silly, like a floating node, and Spice gives a misleading error message.

In the meantime, maybe someone else will have time to dig into the Spice files.
 

Thread Starter

sunney

Joined Sep 3, 2015
9
Thanks for the quick reply.

Unfortunately, I won't be at a computer where I can view Spice files much, if at all, today. If you upload an image (JPG, PNG, etc.) of the schematic, I'd be happy to look at that and see what I can find.

Of course, if the problem really is within the Spice model of a component, that won't help, but sometimes it's something silly, like a floating node, and Spice gives a misleading error message.

In the meantime, maybe someone else will have time to dig into the Spice files.
Thank you for your response ebeowulf17.
Please refer attached screenshot.
 

Attachments

eetech00

Joined Jun 8, 2013
1,894
Hi

The LM5017 model isn't written to converge easily.

Try using the attached modified model file.

Also

I didn't test with the EMI filtering and removed it before further testing.

Here's what I did:
Selected capacitors from component selector (have esr,etc., specified)
Selected inductor from component selector.
Added directives to schematic:
.ic I(L200)=0
.opt abstol=1e-3
removed cshunt directive.

simulation completes in 98.312 seconds.

eT
 

Attachments

ebeowulf17

Joined Aug 12, 2014
3,274
Hi

The LM5017 model isn't written to converge easily.

Try using the attached modified model file.

Also

I didn't test with the EMI filtering and removed it before further testing.

Here's what I did:
Selected capacitors from component selector (have esr,etc., specified)
Selected inductor from component selector.
Added directives to schematic:
.ic I(L200)=0
.opt abstol=1e-3
removed cshunt directive.

simulation completes in 98.312 seconds.

eT
Thanks for jumping in on this one. I probably shouldn't have replied at all, given that my LTspice skills are quite limited - but I figured asking for schematics is always a safe bet!

I'm glad you were able to make sense of it, because I surely wouldn't have figured this one out!
 

Thread Starter

sunney

Joined Sep 3, 2015
9
Thank you eetech00 and ebeowulf17 for your inputs.
I had added reasonable amount of ESR to the voltage sources and capacitors and it is running now.
However still some time when I run it for long time, Time step too small appears now and then. I have read a lot about the issue and came to conclusion that as much as realistic scenario you create better it is.

Sunney
 
Top