LTspice " time step is too small" error

Thread Starter

Tsv_Max

Joined Aug 25, 2022
1
Hi guys,
I am trying to simulate my schematic, by adding a list of values (sweeps) for the resistor R3, but the LT spice stuck in the middle of the simulation itself.
1661445716333.png

Does anyone know that could be the reasons for getting this error. BTW in case of just a simple value (33 ohms) of the resistor R3, the simulation runs propperly, otherwise the erros is present.

I know that one of the reasons could come from the solver, when a discontinuity or infinity result is present, but cannot locate the reason. However, the trouble node, according the error mesage is "X1:74" where X1 is the refdes of an IGBT in my schematic.

Any suggestions.

1661446176994.png
 

eetech00

Joined Jun 8, 2013
3,418
Hi guys,
I am trying to simulate my schematic, by adding a list of values (sweeps) for the resistor R3, but the LT spice stuck in the middle of the simulation itself.
View attachment 274691

Does anyone know that could be the reasons for getting this error. BTW in case of just a simple value (33 ohms) of the resistor R3, the simulation runs propperly, otherwise the erros is present.

I know that one of the reasons could come from the solver, when a discontinuity or infinity result is present, but cannot locate the reason. However, the trouble node, according the error mesage is "X1:74" where X1 is the refdes of an IGBT in my schematic.

Any suggestions.

View attachment 274692
Try this for the value of R3:

{Limit(5,33,X)}

This specifies to keep the value of R3 between 5 and 33 ohms.

remove the cshunt directive.
 
Top