Technofit TR 300 i Treadmill

Thread Starter

metatron

Joined Nov 30, 2023
9
Hi,
I am having issues with a Technofit TR 300 i Treadmill.
As it was being used, there was a pop and the machine stopped working, This "pop" tripped the house circuit breaker in the consumer unit, however the 13A fuse in the mains plug on the treadmill did not blow, as the led red light in the "ON" switch was still illuminated, therefore the power was still going to the circuit board, but the selection display panel on the treadmill was blank. I then checked the circuit board fuse (T 10A H250V) and discovered this had blown.
I replaced this and the display panel immediately lit up.
However there was an error code displayed "E3", so I then proceeded to take the following steps:-

Test the motor with a 24V Drill battery - Result = Motor OK
Cleaned the Optical speed sensor - Result = Treadmill still not working
Unfortunately, I don't know how to test an Optical speed sensor ?
Tested the volts from the circuit board to the Motor - Result = No Output

I think I may have found the reason why the circuit board fuse had blown in the first place, as when I removed the plastic base cover, and vacuumed all the dust, I Noticed a half moon shaped magnet which had randomly attached itself to the transformers body, which looks to have entered the treadmill via the walking belt rotation and immediately must have caused a short circuit or maybe it has been around inside the machine for some time and decided to attach itself to the transformer, However I could be completely wrong as I did not find any obvious burn marks anywhere and this fault could have been caused by other factors ?
So, fellow members, I need help and guidance as how to fix this Treadmill.
Thanks
SoL
 

Thread Starter

metatron

Joined Nov 30, 2023
9
What is the model number on the motor control/main board?
Hi.
sorry for the lateness in response to your request
I managed to remove the circuit board from the treadmill, unfortunately i cannot slide the circuit board out of the aluminium housing, even though i have removed the 3 screws (see Attachment)
Also please see the circuit board model number (see the other attachment)
Thanks
SoLTechnofit TR 300i Circuit Board 1IMG_5242.JPGTechnofit TR 300i Circuit Board 2 IMG_5242.JPGTechnofit TR 300i Circuit Board 2 IMG_5242.JPGTechnofit TR 300i Circuit Board 2 IMG_5242.JPGTechnofit TR 300i Circuit Board 2 IMG_5242.JPGTechnofit TR 300i Circuit Board 2 IMG_5242.JPG
 

Thread Starter

metatron

Joined Nov 30, 2023
9
Technofit TR 300i Circuit Board A IMG_5242.JPGTechnofit TR 300i Circuit Board B IMG_5242.JPGTechnofit TR 300i Circuit Board B IMG_5242.JPG
Hi.
sorry for the lateness in response to your request
I managed to remove the circuit board from the treadmill, unfortunately i cannot slide the circuit board out of the aluminium housing, even though i have removed the 3 screws (see Attachment)
Also please see the circuit board model number (see the other attachment)
Thanks
SoLView attachment 308949View attachment 308950View attachment 308950View attachment 308950View attachment 308950View attachment 308950
Sorry guys my computer is playing up !!!!
 

Attachments

dl324

Joined Mar 30, 2015
16,897
Continuing from your duplicate thread that was locked...

I wanted to see if there was anything preventing the board from sliding out.

Whatever you do, don't apply a lot of force or you risk breaking something.
 

Thread Starter

metatron

Joined Nov 30, 2023
9
What is the model number on the motor control/main board?
hi,
the attachment shows the circuit boards model number, but it is partly obscured as i cannot slide the circuit board out of the aluminium housing/panel etc......i did not want to give you the wrong model number details......or perhaps you can actually recognize or identify the model and /or the number from the attachment ?
PS. Also, I assume the motor control is also a component on the circuit board.......or is that a separate component to the circuit board ?
Thanks
 
Top