Router to router configuration problem

Discussion in 'Computing and Networks' started by cmartinez, Nov 23, 2016.

  1. cmartinez

    Thread Starter AAC Fanatic!

    Jan 17, 2007
    5,358
    6,284
    My ISP installed an Alcatel Lucent i-240w-q router in my home last year, and I'm quite pleased with it.
    A few months ago, I connected my smart TV (LG brand) directly to that router using a straight (B to B) ethernet cable, and things have been happily working just fine ever since.

    There's a small service room in my house that I'm converting into a workshop, and that cable runs right beside it. So what I did was cut the cable right there, and installed another router (configured as DHCP) with the intention of connecting my laptop to one of its LAN outputs, and the TV to another one. For this purpose, I used a crossed ethernet cable (configurated as A at one tip, and B on the other one) to connect Router #2 to Router #1.

    Here's a diagram of how I did things:

    Capture.JPG


    ethernet-cable-color-coding_add-by-nasar-buneri-03459371871.jpeg

    Almost everything is working just fine. BUT... my smart TV can no longer connect itself to Netflix, nor any other services. If I disconnect Router #2, and reconnect the TV directly to Router #1 (using a straight ethernet cable), things go back to normal.

    My laptop, however, works great when I connect it to LAN1 or LAN2 of Router #2. But I've also noticed that when my phone is connected to Router #2's WiFi, then Whatsapp stops working too!
    It seems that there is some sort of "live" protocol that Router #2 is not allowing to pass through.

    What's going on? How can I configure things to make Netflix and Whatsapp work through the switch?
     
  2. djsfantasi

    AAC Fanatic!

    Apr 11, 2010
    3,502
    1,266
    Have you tried connecting the routers with a straight through cable? Most modern network equipment no longer needs a crossover cable.
     
  3. cmartinez

    Thread Starter AAC Fanatic!

    Jan 17, 2007
    5,358
    6,284
    Yup... I've already done that. And when I did, things stopped working altogether!
     
  4. joeyd999

    AAC Fanatic!

    Jun 6, 2011
    3,945
    5,340
    You need a switch for #2. Not a router.
     
    Robert Murphy and cmartinez like this.
  5. cmartinez

    Thread Starter AAC Fanatic!

    Jan 17, 2007
    5,358
    6,284
    But can't router #2 be configured as a switch?
     
  6. eetech00

    Senior Member

    Jun 8, 2013
    1,123
    227
    Hi

    First, its important to know what the model and make of your new router to make it easier to find its capabilities.

    Generally, if the router has a built in switch, connections don't require a crossover cable.
    Did you make the cables yourself?

    Try disconnecting router 2 WAN port, then re-connect one of router 2's LAN ports to router 1 LAN port. Disable router 2's DHCP and use DHCP from router 1.
     
    cmartinez and Robert Murphy like this.
  7. joeyd999

    AAC Fanatic!

    Jun 6, 2011
    3,945
    5,340
    Yes. Hook LAN1 of router 1 to a LAN (not WAN!) port on router 2. Turn off DHCP on router 2.
     
    cmartinez and djsfantasi like this.
  8. shteii01

    AAC Fanatic!

    Feb 19, 2010
    4,385
    692
    ^ what he said.

    1. You can only have ONE dhcp service on the network. Right now both routers are doing DHCP, which is wrong. Like j man said, turn off dhcp on one of the routers.
    2. Routers have several configurations. If you did not mess with the configurations, then both routers are probably setup as Router or Router-Bridge. You don't want either. You probably want one of them set as a bridge. The device that provides the connection to internet should stay as Router/Router-Bridge and it should be the device that provides DHPC for your home LAN.
    3. Normally when dealing with cascading network setup you use uplink port on the device that is further down in the cascade. Because you use port that is dedicated to uplinking, you use a regular network cable, no need for crossover cable. It seems that you are trying to turn one device from router into a hub. This is fine. Get the manual and find out which port of the hub is the uplink port, use regular cable to connect to the router from that uplink port.
     
    cmartinez likes this.
  9. cmartinez

    Thread Starter AAC Fanatic!

    Jan 17, 2007
    5,358
    6,284
    Thank you all for your very helpful replies.
    Apparently, it has three simple options: DHCP, Static and PPPoE. Which one do I use?

    I took screen shots of the Static and PPPoE options in the device's configuration home page. (The DHCP option has no parameters to be configured other than the name and password of the wireless networks)

    This is what the Static option looks like:

    43cfb48f-87a2-4531-9c34-93c31ca19a7f.jpg


    And this is what the PPPoE option looks like:

    1ad83949-b397-41d1-aaad-22d47ff42bf9.jpg
     
  10. joeyd999

    AAC Fanatic!

    Jun 6, 2011
    3,945
    5,340
    This depends on how your ISP is configured. Call and ask.
     
  11. eetech00

    Senior Member

    Jun 8, 2013
    1,123
    227
    The screen shots you've posted are for the WAN port configuration. If you connected router 2 like I suggested in post #6, then router 2 is connected as a switch. The WAN port is not being used, so those settings can be ignored. If you used this as a router connected to the ISP's service, then these settings would be set as required by the ISP (as Joeyd999 stated in post #10). There should be a separate DHCP settings page on router 2 to configure DHCP for devices connected to the LAN ports (this should be disabled).
     
    cmartinez likes this.
  12. cmartinez

    Thread Starter AAC Fanatic!

    Jan 17, 2007
    5,358
    6,284
    I'll try that today later on, thanks. If things don't work out, I'll call my ISP like Joey suggested... though they're not known for their promptness...
     
Loading...