Question About Altium PCB Routing

Thread Starter

BlackMelon

Joined Mar 19, 2015
143
Dear All,

I'm new to Altium. In the first picture, I try to route the top layer as in white circle (try to make the brown connection line aligned with x-axis). However, after I routed, the result is quite sloppy (2nd picture). Is there any key to make the trace aligned with the x-axis?
 

Attachments

Jon Chandler

Joined Jun 12, 2008
429
I don't know if this works in Altium, but it does in Eagle and EasyEDA.

In your example, start the track from the pad on the right, and extend it straight left. End it where you want the track to bend. You should get a straight horizontal line even through it's not on the grid.

Then start the track from the pad on the left. Click at the point where the bend should be, then angle up. They should connect when they meet.

Screenshot_20221020_175940_Edge.jpg
 

Thread Starter

BlackMelon

Joined Mar 19, 2015
143
How many clicks do you use to draw the horizontal segment?
I used two clicks.


I don't know if this works in Altium, but it does in Eagle and EasyEDA.

In your example, start the track from the pad on the right, and extend it straight left. End it where you want the track to bend. You should get a straight horizontal line even through it's not on the grid.

Then start the track from the pad on the left. Click at the point where the bend should be, then angle up. They should connect when they meet.
Oh! It's working! Thank you soooo muccchhh!!!!!!!!!!!!!!!
 

Thread Starter

BlackMelon

Joined Mar 19, 2015
143
I attached the image for those who don't get Jon Chandler's method start at picture AA and end at CC.

Additional info:
The method works when you set the corner of the route to 45 degree only(see picture AA). You can't do it with round corner or 90 degree.
 

Attachments

Top