Problem while implementing a circuit.

Discussion in 'General Electronics Chat' started by Saify, Mar 29, 2019.

  1. Saify

    Thread Starter New Member

    Mar 29, 2019
    7
    0
    I was working on a servo motor control circuit using variable resister . When I implement the whole circuit on the breadboard, the servo motor was just vibrating instead of working. I use mini servo motor(SG90) but in project diagram SG5010 is used. Is that may cause any problem.
    Thank you

    this is the project that I'm trying to
     
  2. MaxHeadRoom

    Expert

    Jul 18, 2013
    18,847
    5,890
  3. djsfantasi

    AAC Fanatic!

    Apr 11, 2010
    5,467
    2,067
    Can you post clear, bright, closeup pictures of both sides as your attempt. I found the exact schematic as your video. We all know how reliable online schematics are.
     
  4. djsfantasi

    AAC Fanatic!

    Apr 11, 2010
    5,467
    2,067
  5. bertus

    Administrator

    Apr 5, 2008
    19,923
    4,146
    Hello,

    Do you use the correct connections for the SG90?

    SG90_connection.png

    Bertus
     
  6. Saify

    Thread Starter New Member

    Mar 29, 2019
    7
    0
  7. bertus

    Administrator

    Apr 5, 2008
    19,923
    4,146
    Hello,

    Can you read the schematics in the link?

    ServoController.jpg

    Bertus
     
  8. Saify

    Thread Starter New Member

    Mar 29, 2019
    7
    0
    May I know it's working
     
  9. bertus

    Administrator

    Apr 5, 2008
    19,923
    4,146
    Hello,

    From the given page:

    A pot can be used to control the position of the servo by using the following circuit.
    It produces a positive pulse between about 0.9 milliseconds and 2.1 milliseconds.
    The off period between pulses is about 40 milliseconds.
    This can be shortened by reducing the value of the 3M3 resistor.

    Bertus
     
  10. Saify

    Thread Starter New Member

    Mar 29, 2019
    7
    0
    Thank you
     
Loading...