Olympic rapid fire training aid

Thread Starter

MarkAB

Joined Feb 27, 2016
80
Could not wait so did this and after closing the switch Q1 led come on for 2min 4 sec and then goes off, then Q2 led comes on for 14 sec and then all stays off.
Wow it works ! super happy thanks Bernard. Guess when I get the pots I can adjust timings?

Can't wait for stage two.
 

Bernard

Joined Aug 7, 2008
5,397
Not much time available today so just added Q3. Sorry for shadow where paper was spliced. C 5 = 10 uF; no ground connection from Q3-2. R13 = 1 meg. pot.Range Timer 3A 00000.jpg
 

Bernard

Joined Aug 7, 2008
5,397
Added last step- Q4. After 78 sec. ,with R 12 =1 meg. , G LED should light for about 8 sec.
Now modify all 555 resets, P-4, by connecting all to a common buss , or daisy chained to include R17 & Q5, NPN transistor 2N3904. I forgot to remember the goof on Q4 reset, for now leave out R7 & D3;Range Timer 3B 00000.jpg will need to invert trailing edge pulse from Q3 for a reset for Q4.
 

Bernard

Joined Aug 7, 2008
5,397
Had to go back to page 1 to remember what we were doing. Red LED is on except when green is on ???
Red LED is on when Q1 or Q2 are on, so we skip Q4 & just OR the outputs into 300 ohm, & red LED. I'll correct the last schematic. Sorry for my confusion.
 
Last edited:

Bernard

Joined Aug 7, 2008
5,397
Maybe the last version. Not sure of green LED Vf, measured an old one as 2.2V @ 20 mA so picked
150 ohm for about 20 mA. Red now down to 120 ohm until we know more about LED's.Range Timer 3C 00000.jpg
 

Thread Starter

MarkAB

Joined Feb 27, 2016
80
Had to go back to page 1 to remember what we were doing. Red LED is on except when green is on ???
Red LED is on when Q1 or Q2 are on, so we skip Q4 & just OR the outputs into 300 ohm, & red LED. I'll correct the last schematic. Sorry for my confusion.
A beep signals the start of a red led for 1 min then another beep and red led stays on for another 7 sec then changes to green for 4 sec and back to red starts all over again.
 

Thread Starter

MarkAB

Joined Feb 27, 2016
80
This is a section of the Olympic rapid fire rules:


I have added my comments within the brackets and highlighted in bold what is relevant.



Officer gives the command “LOAD,” (first beep) athletes must prepare

themselves for their series within one (1) minute;

f) When one (1) minute has expired, the Range Officer will give

the commands:

“ATTENTION” (second beep)

The red lights must be switched on or if

paper targets are used, they must be turned

to the edge-on position and the athlete must

bring his pistol to the READY position.

After a delay of seven (7) seconds (+/- 0.1

second) either the green lights come (for a time of 4 sec)on, or

the target must turn to face the athlete.

(back to the red lights, and restart the sequence)
 

Bernard

Joined Aug 7, 2008
5,397
There are many choices for the beeper also depending on how loud it should be. Range Timer #2 uses a sounder with built in oscillator with time on controlled with a 555, Q4. My R-S sounder is pretty puny at 6V.
The 555 can be eliminated by capacitive coupling , 100 uF , Q1-2 pins 3 in to a positive OR gate like Red LED
, the sounder taking the place of R & LED.
Q4 pins 8 & 4 go to +6V
If using a speaker, Q4 can be made into an oscillator to drive the speaker.Range Timer #2 00000.jpg
 

Thread Starter

MarkAB

Joined Feb 27, 2016
80
Maybe the last version. Not sure of green LED Vf, measured an old one as 2.2V @ 20 mA so picked
150 ohm for about 20 mA. Red now down to 120 ohm until we know more about LED's.View attachment 105895
Just finished this one but cant get red and green led to work so must have done something wrong!
might need to pull everything out and start again.
 

Bernard

Joined Aug 7, 2008
5,397
Do not be to hasty in breaking it down. What version do you have on breadboard- Range Timer C ?
Q1-2 were working before so check Q1-2-3, pins 4, are they high, if not check Q5 connections. Is R 17
connected? It should pull all pin 4s high if Q5 is off. A reversed or really leaky C8 , or missing R15 could hold pins 4 low.
 

Thread Starter

MarkAB

Joined Feb 27, 2016
80
Yes range timer C.
I had confused the 555 chips, now I have numbered them. Got the two led working but still no red or green. will check what you have noted tomorrow as too tired now.
Thanks Bernard had loads of fun and very good progress.
 

Thread Starter

MarkAB

Joined Feb 27, 2016
80
Do not be to hasty in breaking it down. What version do you have on breadboard- Range Timer C ?
Q1-2 were working before so check Q1-2-3, pins 4, are they high, if not check Q5 connections. Is R 17
connected? It should pull all pin 4s high if Q5 is off. A reversed or really leaky C8 , or missing R15 could hold pins 4 low.
All pins 4 are high but still no red or green led's
Could it be that I replaced the !meg pot's for 1meg resistors?
 

bertus

Joined Apr 5, 2008
20,328
Hello,

When you used 1M resistors on the position of the 1M pots, the time will be maximum.
It probably still will work, but slower as expected.

Bertus
 
Top