Mobility scooter problems

Thread Starter

TraceyC

Joined Jan 8, 2020
8
Hi all, we bought a second hand tga mobility scooter, it works fine sometimes and then if left for anything for 10min to 1 hour it will go into fault mode 8beeps. We have checked everything, battery, motor voltage, wiring but nothing seems to be wrong with it. Any advice would be greatly appreciated. Thanks
 

AlbertHall

Joined Jun 4, 2014
9,009
Hi all, we bought a second hand tga mobility scooter, it works fine sometimes and then if left for anything for 10min to 1 hour it will go into fault mode 8beeps. We have checked everything, battery, motor voltage, wiring but nothing seems to be wrong with it. Any advice would be greatly appreciated. Thanks
What gets it back into the working condition again?
 

Thread Starter

TraceyC

Joined Jan 8, 2020
8
Welcome to AAC!
Scooter model/age? Any user manual/instructions/schematic?
Tga eclipse mobility scooter, I was told its 4years old but I have a feeling its older. Operator instructions states - 8 beeps fault is a controller fault indicated - check all connections. We have done this many times to no avail.
 

Alec_t

Joined Sep 17, 2013
10,708
This appears to be the relevant manual.
Is the controller easily removed (without cutting wires)? Take photos before unplugging anything!
 

Thread Starter

TraceyC

Joined Jan 8, 2020
8
Tga eclipse mobility scooter, I was told its 4years old but I have a feeling its older. Operator instructions states - 8 beeps fault is a controller fault indicated - check all connections. We have done this many times to no avail.
I have asked Tga uk for the service manual to which they replied "they don't have it anymore" I also asked for circuit diagrams but they don't reply when I ask for that.
This appears to be the relevant manual.
Is the controller easily removed (without cutting wires)? Take photos before unplugging anything!
Yes, thanks that's the manual I have for it but it's not much use. We have taken out the controller and every appears to be ok, we have checked all the wires, checked the batteries and voltage whilst run all ok, also checked the motor voltage whilst running and all ok, when the fault happens theres no voltage going to the motor. I'm starting to think theres a fault in the main controller but it's not an obvious one.
 

Alec_t

Joined Sep 17, 2013
10,708
I would think inside the main controller. Someone on ebay is advertising a used one. From their pic it looks like the controller has 2 screws holding the lid in place, and the multi-way sockets look like they have plastic lugs which could be pressed in to release the sockets from the lid. (But beware; plastic several years old is often brittle!).
 

Thread Starter

TraceyC

Joined Jan 8, 2020
8
I would think inside the main controller. Someone on ebay is advertising a used one. From their pic it looks like the controller has 2 screws holding the lid in place, and the multi-way sockets look like they have plastic lugs which could be pressed in to release the sockets from the lid. (But beware; plastic several years old is often
 

Thread Starter

TraceyC

Joined Jan 8, 2020
8
Back again.
So we changed the pcb in the top controller as it looked a dodgy the scooter worked a treat for a few days and now it's back faulting again. Any ideas?
 

Thread Starter

TraceyC

Joined Jan 8, 2020
8
Is it exactly the same fault as before?
Yep, 8 beeps fault. Would it/could it be a loose wire that's coming loose with use. It worked perfectly for a week no problems at all after I changed the pcb in the top controls. It was used a good bit and for a good while each time during the week then all of a sudden it just stopped dead and faulted 8 beeps. Now the fault is intermittent again like before.
 
Top