MIDI-arduino project working perfect with one computer but not with other two

Thread Starter

parabrisa

Joined Jun 9, 2016
3
http://forum.arduino.cc/index.php?topic=406104.msg2793486#msg2793486
I made a project to control 3 DC motors with MIDI and Arduino Uno. I use Ableton live (also worked with sonar8) and Hairless Midi (works fine with midiyoke and loopMIDI).

It works perfect with one of my PC laptops, but not working with the other two, that are my professional computers, and newer. All of them working with Windows7.

Hairless Midi debugs the same messages on 3 computers, and the blink light on the arduino blinks the same and when it is supposed to do, but the motors do not react on the two other laptops.

I tried to change the USB cable but no success...

It is not a code problem, it works perfect on one computer.

I did not find any post about...some clue?
Thanks in advance.
 

bertus

Joined Apr 5, 2008
20,448
Hello,

Are all USB ports 2.0 devices?
There are some devices that will have troubles with 3.0 USB ports.

Bertus
 

Thread Starter

parabrisa

Joined Jun 9, 2016
3
Thanks for your reply Kermit2.

I am not using the port for power, I use a separate power supply.

I tried also running it without the computer power supply (only with the battery), just to try, because some time ago with the same computer I burnt a Rumba board uploading the firmware through USB, but I solved that and was a design problem of the boards.
 
Top