Make: Electronics Experiment 7 (Relay-Driven LED)

Thread Starter


Joined Jan 18, 2015
Hi there,

I'm reading Make: Electronics to recover my college electronics knowledge.
I've assembled a circuit (using a breadboard, during it with alligators is a nightmare) and it doesn't really work.

So here is a circuit I'm trying to do:

Here is what I've done:

Resistor is 680Omh, LEDs positioned properly (cathodes facing right - to the negative, green wires).
When I press red button (bottom left corner) I can hear the relay is switching, top led goes off, but bottom one doesn't start.

I've tried few things:
1) replace a relay component
2) replace LED
3) tried to measure voltage at 2nd led pins when I press red button

1 & 2 doesn't help.
Voltage goes up to 0.4-0.6 for half a second and then drops to zero when I press/release the button.
Can't figure out what's wrong. My only guess was that DPDT relay I've bought isn't the correct one, but I found the data sheet and it says that coil voltage is 12v - came as my circuit voltage.

Here are few more pictures to get a better understanding what's happen there.


Thread Starter


Joined Jan 18, 2015
Thanks Max, that actually worked. I switched red probe from push button & non-working LEDs anode and now everything is working!