M2-ATX Power Supply problem

Thread Starter

shlomis123

Joined Apr 20, 2024
1
Hi,
I am trying to activate an old robot (WhiteBoxRobotics 914 PC-BOT) as part of a lab project I am doing, and it is activated by two M2-ATX power supplies.

The robot had two old ones (probably from around 2006-7), and they had a problem of only outputting 12V without outputting 5V (which is needed for some of the robot's features), as shown in image 1.
I bought a new pair of M2-ATXs and connected it the exact same way as the old ones, where one of them (the main one, left in the image) is connected in mode P1 (where a single jumper is connected in the A port) and the other one is working in PSU mode (no jumpers at all), as shown in image 2.

When I tried to use the robot the same way as before, the PSU one did not seem to output any current at all.

As shown in mini-box's website (the company that manufactures it) they updated the way PSU mode works in 2008~, and featured a UPS mode.
I am a computer science student and not engineering student, I have no experience with electronics what so ever.
Please help on making the PSU mode work as it should, outputting 12V and 5V.
Thanks!

I tried to upload the images directly but failed, so I am linking it:
image 1 (the old ones):
https://ibb.co/txvSPpS

image 2 (the new ones, connected to the robot):
https://ibb.co/LxtXcT6

The specs of the new ones:
https://resources.mini-box.com/online/PWR-M2-ATX/PWR-M2-ATX-manual-engl.pdf

The specs of the old ones:
https://static.mini-itx.com/store/information/m2-atx-manual.pdf

The new UPS mode:
https://resources.mini-box.com/online/PWR-M2-ATX/UPS-mode-functionality.pdf
 

MisterBill2

Joined Jan 23, 2018
19,055
At one time, back in the PC era , the switcher power supplies high current 5 volt output demanded that a serious load current be drawn to hold the voltage down to 5 volts. The regulation was not able to hold five volts with no load. So without an adeqate load the supply will go into over-voltage shutdown.
 
Top