LTSpice "standard.xxx" file problem

Thread Starter

bordonbert

Joined Feb 21, 2012
35
Hi guys. I'm having trouble with the locations and/or working with LTSpice's "standard.xxx" files. Let's consider the BJT version standard.bjt.

I know there is a default LTC version of standard.bjt in the "C:\Program_Files\LTC\LTSpiceXVII\lib\cmp" folder. This, as I understand it, is the one updated periodically by Analog Devices so I assume it will be overwritten along with others there. The working version which LTSpice uses for this standard file is, as I understand it, in the "...My_Documents\LTSpiceXVII\lib\cmp" folder. This is the one that LTSpice picks up as it starts. I assume that the file needs copying across from C:\Program_Files to ...My_Documents whenever it is updated by LTC

Assuming that is all correct, I am trying to set up what seems logical to me. I want to keep the C:\Program Files\...\standard.bjt file untouched by my own additions which will then be held in a different file in a different place. I could add this location into LTSpice via the Control Panel\Sym. & Lib. Search Paths. I would have thought it would also be possible to just add it into the existing "...My_Documents\LTSpiceXVII\lib\cmp" folder alongside the working standard.bjt file. It will then be possible to have a batch file setup to copy a new version across whenever it detects that the file changes without upsetting my own additions in any way. I only need to run it at the start of a LTSpice session. But there must be something I am thinking or doing which is bonehead dumb as I can't get the most basic aspect of this to work! I can't get LTSpice to pick up the standard.bjt file and my own and offer components from both files.

To be blunt, should I be naming that additional file which I will use to add my own models something like "mydevices.bjt" and simply putting it in the MyDocuments\LTC\LTSpiceXVII\lib\cmp working folder?
 
Top