Invalid library found in C:\

Thread Starter

mkbutan

Joined Sep 30, 2008
296
hi there ,
I am getting this in the Arduino IDE v1.8.13 ...
what does it means why is it coming ..
i never noticed it before

Invalid library found in C:\Users\mkbut\Documents\Arduino\libraries\Arduino-Test-master: no headers files (.h) found in C:\Users\mkbut\Documents\Arduino\libraries\Arduino-Test-master
i can upload my Arduino codes ...
after all the Upload this line appears...

I think its not good ...
any help
 

Thread Starter

mkbutan

Joined Sep 30, 2008
296
Thanks for your valuable time
it appears in all the .ino even if we upload the blank
Code:
void setup() {
  // put your setup code here, to run once:

}

void loop() {
  // put your main code here, to run repeatedly:

}
Invalid library found in C:\Users\mkbut\Documents\Arduino\libraries\Arduino-Test-master: no headers files (.h) found in C:\Users\mkbut\Documents\Arduino\libraries\Arduino-Test-master
Executable segment sizes:
IROM : 228400 - code in flash (default or ICACHE_FLASH_ATTR)
IRAM : 26352 / 32768 - code in IRAM (ICACHE_RAM_ATTR, ISRs...)
DATA : 1248 ) - initialized variables (global, static) in RAM/HEAP
RODATA : 688 ) / 81920 - constants (global, static) in RAM/HEAP
BSS : 24840 ) - zeroed variables (global, static) in RAM/HEAP
Sketch uses 256688 bytes (24%) of program storage space. Maximum is 1044464 bytes.
Global variables use 26776 bytes (32%) of dynamic memory, leaving 55144 bytes for local variables. Maximum is 81920 bytes.
esptool.py v2.8
Serial port COM5
Connecting....
Chip is ESP8266EX
Features: WiFi
Crystal is 26MHz
MAC: 18:fe:34:de:a2:7d
Uploading stub...
Running stub...
Stub running...
Configuring flash size...
Auto-detected Flash size: 4MB
Compressed 260848 bytes to 192747...
Wrote 260848 bytes (192747 compressed) at 0x00000000 in 17.2 seconds (effective 121.5 kbit/s)...
Hash of data verified.

Leaving...
Hard resetting via RTS pin...
Invalid library found in C:\Users\mkbut\Documents\Arduino\libraries\Arduino-Test-master: no headers files (.h) found in C:\Users\mkbut\Documents\Arduino\libraries\Arduino-Test-master
its coming in esp and Arduino Nano also
 

AlbertHall

Joined Jun 4, 2014
10,572
The files in C:\Users\mkbut\Documents\Arduino\libraries\Arduino-Test-master do not match the requirements for a valid library. That is what it is complaining about.
Move that whole directory out of the library folder.
 

Thread Starter

mkbutan

Joined Sep 30, 2008
296
thanks dear I think the Problum is solved I have removed the said Folder from the Libraries folder (Cut & Paste) outside the Librarie Folder ...
Thanks @ AlbertHall

Move that whole directory out of the library folder.
Thanks @ xox
You probably created a sketch in a folder used by one of Arduino's libraries (see here, for example).

Thanks for the same
 

Ian Rogers

Joined Dec 12, 2012
810
This normally happens when the folder name and class name do not match.. What is the real name of the class and the name of the folder it's in.

EDIT... Sorry I didn't refresh the page this morning..
 
Top