Induction Cooktop Repair Help

Discussion in 'Technical Repair' started by wess.vic, Dec 27, 2015.

  1. wess.vic

    Thread Starter New Member

    Dec 27, 2015
    3
    0
    I recently was given a vollrath 240volt induction cooktop that didn't work. I tried turning it on and it blew apart the fuse every time. I then knew there had to be a serious short in it to have such a high in rush current to explode the fuse ceramic casing. I then did some further investigating and found one out of the three transistors for the coil was blown out the back. I soldered in a new one and a micro controller for the transistor just in case it was faulty to. I then attempted to start it again and it still blew a fuse. I then did some metering and found the circuit on the motherboard where the ac is changed to DC through a solid state rectifier semiconductor. The dc voltage ran to a current sensing transformer. I looked over the transformer and realized the 240v going in was just a large piece of wire holding it in. But it also crossed the legs at this point. So I decided to remover the transformer and then start it. It worked but since the transformer was removed the thermistor micro controller were not receiving any voltage. I then bought a new transformer soldered it in and it still doesn't work. I then came to the conclusion that the bridge rectifier was the malfunction and was not producing a dc current. But before I bought anything more I wanted to hear someone else's thoughts on what it could be thanks, victor
     
  2. GopherT

    AAC Fanatic!

    Nov 23, 2012
    7,108
    5,748
    Sounds like a bargain so far. Don't burn your house down or you will have a really good story to tell about your gift.
     
  3. wess.vic

    Thread Starter New Member

    Dec 27, 2015
    3
    0
    Is there any advice or help you can give me on it?
     
  4. GopherT

    AAC Fanatic!

    Nov 23, 2012
    7,108
    5,748
    Make an estimate of how much you think it will cost to repair. E.g. $300

    Divide that number by your probability of success (e.g. 30%), $300/0.30 = $1000.

    Check the price of a used one from a reputable shop (and a new one).

    Bring it to the junk pile. Sell the valuable bits on eBay (if you are sure they work, or if you are willing to give refunds).
     
    sivark1980 and Johann like this.
  5. sailorjoe

    Member

    Jun 4, 2013
    361
    63
    The second photo shows only two diodes, so a full wave rectifier, but not a bridge rectifier. Maybe the other diodes are somewhere else on the board. I found this schematic for a Vollrath cooktop, but I'm not sure it's exactly your model. Poke around, though.
    http://openschemes.com/2010/12/09/circuit-analysis-of-the-1-8kw-induction-hotplate/
    Not sure exactly what model number you have, but I found these docs.
    http://www.webstaurantstore.com/documents/pdf/osi_mirgebuffetinductionwarmer_manual.pdf
    http://www.webstaurantstore.com/doc...onmiragebuffetwarmer_l36009_en_2015-02-26.pdf
     
  6. wess.vic

    Thread Starter New Member

    Dec 27, 2015
    3
    0
    There's two diodes and then there is a semiconductor with 4 pins. Ac in dc out. Here's a data sheet on that bride rectifier. In the pictures right beside the transistors you can see were I took it off. GBJ25J semtech rectifier
     
  7. Alec_t

    AAC Fanatic!

    Sep 17, 2013
    7,004
    1,446
    A gadget every husband should have :).
     
    strantor likes this.
  8. Ramussons

    Active Member

    May 3, 2013
    622
    104
  9. gopal909

    New Member

    May 28, 2008
    4
    0
    IN MY OPINION YOU SHOULD CHECK ALL ACTIVE COMPONENT ONE BY ONE. THEN YOU WILL FIND DEFECTIVE COMPONENTS.
     
  10. dendad

    Member

    Feb 20, 2016
    479
    125
    Be very careful when playing with this as it is a potentially lethal device!
    And to save your nerves a bit, try to power it up with a 240V 100W incandescent lamp in series with the mains in. This will limit the input current to non smoking levels hopefully, and let you test your repairs. The lamp will flash when power it first applied, that drop down to a faint glow or no glow at all. If it stays lit, there is still a problem.
    The cook top will not be able to be run like this but powered in standby mod it should be ok.
    As said above, check all semis for shorts. make sure all the diodes work only 1 way as a diode should, and no transistors are shorted. Look also for capacitors bulging or leaking. Electrolytic caps drying out are one of the biggest killers of electronic switching devices.
    Measure the capacity of the electros and if in doubt, replace them. You may need to chase down low ESR caps as it is a high frequency switching device I think, so there will be high currents through the capacitors.
    Once again, PLEASE BE CAREFUL!
    Capacitors can hold their charge for quite a while and so after you have powered it off, check for any charge left in the caps. people have been killed buy turned off power devices that have retained a charge.
    If you are unsure about what any of this means, I would recommend you do not touch it, but get someone else who has the appropriate expertise to look at it for you.

    I'm a bit concerned that you said you removed the current sensing transformer. And if I understand correctly, that bit of wire holding it in is not just holding it in, but is the primary of the transformer. Without that wire, there will be no power supplied to the rest of the circuit. The current sensing transformer would most probably be among the last pieces to give trouble.

    And... "and a micro controller for the transistor"????
    Do you mean the micro controller that is the brains of the cooker? If so, did you get another from the manufacturer that is programmed? In not, you cannot just put a new micro controller in an expect it to work. Most need to have the program burned in first.
    It just may be your terminology that is a bit off, but that in itself rings alarm bells to me.
    Maybe you should start working with electronics on a simpler, safer project first.

    I'm not trying to put you down but am truly a bit worried for your safety.
    What previous experience do you have?
     
    Last edited: Jul 6, 2017
  11. shortbus

    AAC Fanatic!

    Sep 30, 2009
    4,511
    2,549
    You guys do realize this is an almost 2 year old thread?
     
  12. OBW0549

    Well-Known Member

    Mar 2, 2015
    1,769
    1,443
    Probably not, nor that the TS hasn't even logged onto AAC since the day after he posted the above.
     
    shortbus likes this.
  13. dendad

    Member

    Feb 20, 2016
    479
    125
    Oh, am I embarrassed!
    I'd best look at it a bit better next time!
     
  14. dl324

    Distinguished Member

    Mar 30, 2015
    4,731
    1,026
    The old interface gives a very noticeable warning when replying to old posts:
    upload_2017-7-6_18-39-31.png
    Apparently you have to click the the button indicating that you're aware it's an old thread and you want to reply anyway.

    If the new interface doesn't have the warning, you could ask for it to be implemented.

    EDIT: Never mind. It was @gopal909 who would have gotten the warning. Blame it on him.
     
    shortbus likes this.
  15. dl324

    Distinguished Member

    Mar 30, 2015
    4,731
    1,026
    Guess it wouldn't do any good to chastise him about his grammar, or lack thereof...
     
Loading...