Importing a manufacturer spice model to LTspice

Thread Starter

Xavier Pacheco Paulino

Joined Oct 21, 2015
726
I have attached the folder of a PTC model I downloaded from the manufacturer page. The folder has many files, but I believe they are mostly simulation examples. This is I what I did to import the model, correct if I'm wrong:

1. Copy the .lib file to LTspice sub folder
2. Copy all of the .asy files into a single folder inside the LTspice sym folder

Does this assure the model and the symbol are going to be combined?
 

Attachments

Thread Starter

Xavier Pacheco Paulino

Joined Oct 21, 2015
726
hi XPP,
What I do first time around is to load all the files/models into the same folder, then check out the models by using test asc files in the same folder.
All your asc files run OK, except the TEST PTCvi, which does not converge.

E
Thank you. Yes, the tests files run OK. But what I want to do is to use this device in another circuit. Should I copy the whole folder to LTspice directory or copy individual files according to the extension as I did in post #1?
 

ericgibbs

Joined Jan 29, 2010
8,715
hi.
Are you using Windows 10 with LTS XVII.?
There has been a change to where you put the files.
E
 

ericgibbs

Joined Jan 29, 2010
8,715
hi,
At the C:\Program Files\LTC level.

I have placed the Lib file in the LTS Lib folder and Sub folder
In the Sym folder I have added a folder named PTC and placed the asy files in that folder.
Also in the Sub folder I have placed the Txt files.

After running LTSpice the files in the Documentation folder are updated to match these additions.
The Program is now finding the models.

I sure there must be an easier way to do this operation, I was used to XP Pro with LTS XVI

E
 

Alec_t

Joined Sep 17, 2013
10,350
I usually just dump the new files directly in the appropriate sub or sym folder in the LTS section on the Documents path.
 
Top