IAR error: failed to initialize device

Discussion in 'Embedded Systems and Microcontrollers' started by Vindhyachal Takniki, Apr 4, 2015.

  1. Vindhyachal Takniki

    Thread Starter Member

    Nov 3, 2014
    1. I am using MSP-EXP430G2 with MSO430G2553 on it.

    2. While debugging I get below error:
    Emulator: fatal error : failed to reinitialize
    Session aborted

    3. IAR version: 6.20.1

    4. On board all the jumpers: test,rst,rxd,txd & vcc are connected.
    I have checked voltage on VDD pin, its : 3.56V
    In PC->Device Manager-, com3 is successfully connected.

    5. After failures, I have also tried downloaded "msp430.dll_developer_package_rev_3.04.003.004" & replaced "HIL.dll" & "MSP430.dll" files in IAR/430/bin directory also.

    6. I have seen that several people had similar issues.

    7. Code is attached for setting if someone can check.

    8. I have selecetd project options->FET debugger-> SPI-BY interface. But still same error.
  2. MrChips


    Oct 2, 2009
    Looks like either your MSP-EXP430G2 LaunchPad is bad or your IAR installation is corrupted.