Has any one worked with Dissolved oxygen sensor from Kacise, Need their expertise

Thread Starter

ashokraj

Joined Feb 1, 2018
79
I have been working with this sensor and tried to communicate through RS 485 protocol but couldn't!
Issue:
I have followed every instruction as per the instruction manual but when i tried to communicate with the modbus, sensor doesnt respond ( I could able to establish a connection but there is no output from sensor) I have tried the following combinations as per manual .

01 03 00 01 00 02 95 cb-> to read measured value
01 03 00 03 00 02 34 0b->temperature measured value
01 03 00 05 00 02 d4 05-> current output value.

how ever i have plugged and played the low byte register start address and when i sent the below command i have got some output
01 03 00 00 00 02 c4 0B -> sent command

received command from the sensor is ->01 03 04 36 1f 40 0e -- -- ( -- means crc value )
I need to read measured and temperature value.

If some one has worked on this product/ similar product/ please share your insights.

Thanks,
 

Attachments

RS485 can be a nightmare the first time wiring it. You also need terminators on the master AND the slave. On the net documentation for RS485 has issues. Understand RS485 first,

Possibe issues with understanding the documentation.

e.g. Start address
High byte 0x00 Low byte 0x01 means your sending a control A character. Hex 0001 for 8 bits. The spaces don't count.


Each RS485 device has an address. The default is 2.

it looks like to change it, you would have to restore default. Set things up for the default baud rate and change things from there.

Do something easy first. e.g. get the device address or baud rate.

Usually RS485 is usually limited to around 32 devices, so stay under 32 first. Looks like there are ways to extend this.

One thing I noticed, is that they have a default ID of 2 and use ID of 1 as an example. That will cause you ALL sorts of grief.

You might want to write an interactive program that allows you to type commands like 00 10 etc. (CRC)

and even one that has things like "SET ADRESS #" e.g. SET ADDRESS 2.

I got involved in an 8 unit RS485 network after multiple people had literally given up. The problem was getting initial communication. I know it was related to signal definitions where the differential polarity was swapped. It may have involved terminators too.

I was out of the loop once communications was established. We used a converter by MOXA.

This isn't an easy job.


You have to generate the correct CRC. Looks like that will create a mess too. See: https://crccalc.com/

I dug out an oscilloscope to get the signals looking good. Then they sometimes have to be reversed.

There is a whole mess of problems with RS485. e.g. https://www.advantech.com/resources/white-papers/02cb2f4e-4fb2-4a87-be3b-508325bd61d6 So find some whitepapers.

This "Note on RS-485 Pinout Markings: Sometimes a device will be marked with the polarity reversed from normal RS-485 standards where the Data A or TD(A)/RD(A) line is (+) and the Data B line or TD(B)/RD(B) is(-). In a system with 2-wire connections, try reversing the lines to see if the device will respond. In a system with 4-wire connections, try reversing the Receive pair polarity and Transmit pair polarity. If the connections are wrong, you won’t be able to communicate because the data bits are upside down, but swapping polarity won’t damage anything. The marking Rx or Tx may be used instead of TD and RD or in a 2-wire system,Tx, Rx+ and TxRx-, or Dx+ and Dx- for the data lines. Many naming schemes are in use. RS-485 pinouts also have many variations and there is no single standard pinout arrangement or connector type – DB9, DB15, DB25, RJ-11, RJ-12, RJ-45 or DIN connector."

is an IMPORTANT statement quoted from the whitepaper.
 
Last edited:
Top