Getting out of memory message when trying to save Microsoft Project 2010 file

Thread Starter


Joined Sep 27, 2015
I have a Windows XP Pro SP3/32bit laptop with 4 GB of memory that is getting an out of memory error message every time the user tries to save a Microsoft Project 2010 file. He has about 3 Project files open at one time when he tries to save the file. When I check the task manager for memory usage, it is only about half. I have increased the paging file to recommended setting and have turned off the 3D setting within Microsoft Project. I checked Windows updates for any patches for Project and installed them. Maybe there is some hotfix out there that I don't know about or one of the sticks of memory is having a problem. Does anybody have any ideas what could be going on?

Greatly appreciate any help you guys could give,


Joined Apr 5, 2008

How big is the paging file?
The paging file is used to swap memory when needed.
If it is to small, you might get out of memory erros or even hangups.



Joined Apr 11, 2010
To resolve your problem, first replace Windows XP. XP is not supported, there are not any fixes available for it, if you are connected to the Internet or a LAN it is a security nightmare and it is obsolete technology.

All of which may contribute to your problem.

No XP Proselytizer


Joined Oct 1, 2015
One of the methods represented below, can be effective, if not see another ways

Helpful threads with various opinions of experienced users about MPP corruption

Solution created only for totally crashed .mpp files, when other solutions failed Project Repair Toolbox

Because of the way Project stores files, file fragmentation may be the basic cause. To make sure this isn’t the problem: open your .mpp file then select File/Save immediately before doing any other action. Only if you save immediately after opening does Project defragment its .mpp file. If you do not have external links in your file, (i.e. resource pool, master with subprojects, etc.), then a good practice is to always use Save As instead of a straight Save with your file after editing. This helps keep editing clutter from being appended to the file. However, be advised that using Save As with linked files can actually create corruption/bloat due to multiple link paths being created IF the file is not saved back to its original name and path.


Joined Jun 8, 2013
Try setting the paging file to 1.5 time the size of ram. See if that helps.
You can also try deleting the page file, then resetting the size.
(Boot to safe mode command prompt, delete pagefile, reboot, then resize)

djsfantasi is right... Get rid of xp....


Joined Oct 11, 2008
--How much free hard drive space does the laptop have? If very little, that could be causing the issue.

--Consult the MS Support document at I believe MS still has their Fix-It tools available for XP, if the user does not want to do the procedure manually.

--User can also try to tune the windows services that are running. Windows default settings leave a lot of stuff running in the background, not all or even most of which the user actually needs, based on a user's individual use for the PC. These unneeded services can eat into a PC's resources and generally slow everything down. Check out Black Viper's page on WinXP tweaks. I highly recommend it. There are OS tweaks for the Vista, 7, 8, and 10 users as well.

I've not used XP for a while . . . as someone said Microsoft has stopped supporting it (Except for the Windows Embedded Industry, aka "Windows Embedded POSReady", which is said to be based on Windows XP Service Pack 3) and the user does need to be concerned about security if connected to the internet. Suggesting they upgrade to another OS however, while good advice, is beyond the scope of the OP's question.
Last edited: