ESP8266 ESP 12e Not responding to AT Commands

Thread Starter

mkbutan

Joined Sep 30, 2008
296
Hi everyone,How are you?
I have two ESP8266 ESP-12e Wi-Fi Modules ...
I have also updated the Arduino IDE Ver to the Latest one ei 1.6.10 ...
I have also included teh ESP8266 ESP 12 in the Arduino Board Manager to the Latest Ver 2.3.0...
Its Blinking with the BLINK ( Example) ( I have changed its PIN From 13 to 16)
and also changed its Default Delay time from 1000 to say 10000;15000 and so on
its working properly...

Now when I tried to Check the AT Command in ESP8266 ESP-12e after compiling with Arduino IDE BareMinimum it Compile and Load in the ESP and type AT in the Serial Monitor of Arduino it just Display Not on 115200 or 9600 Baud (but at 74880 Baud as below in Quote)
ets Jan 8 2013,rst cause:2, boot mode:(3,7)

load 0x4010f000, len 1384, room 16
tail 8
chksum 0x2d
csum 0x2d
v09f0c112
~ld
now what to do I dont know
kindly guide me
Thanks
 

Attachments

Thread Starter

mkbutan

Joined Sep 30, 2008
296
Hi everyone ,
today I managed to update the Firmware from
https://github.com/nodemcu/nodemcu-firmware/tree/master
with
I am able to send blink LED (pin no 16)codes and make the led blink successfully.
But when i am sending AT commands to the module?
it disappear no function ...
I tried opening the serial monitor and sent "AT" but no reply. Even the command i am sending is not shown on the serial monitor.
I have Set the baud rate to from 300 To 9600 ;74880 115200 to 250000. "Both NL and CR" selected. ...BUT THE GIVEN MASSAGE APPEAR AT
ets Jan 8 2013,rst cause:2, boot mode:(3,6)

load 0x4010f000, len 1384, room 16
tail 8
chksum 0x2d
csum 0x2d
v4022ead8
~ld
I have ESP8266 ESP-12e
Help me how to get AT Commands work
AT
OK
READY
 
Last edited:

Thread Starter

mkbutan

Joined Sep 30, 2008
296
At doesn't work without firmware that has it in it.
Thanks dear sir
I have already changed the Default Firmware with this one
but still Arduino IDE Serial Monitor Doe't show any AT ; AT+GMR ; AT+CWMODE=? ; AT+CWLAP etc...
the latest release for the NodeMCU Firmware is 1.5.4.1-master_20160802 from https://github.com/nodemcu/nodemcu-firmware/releases
but after extracting from
the RAR file does't shows any "*.bin" file
is there any other way to do so.
please help
 

be80be

Joined Jul 5, 2008
2,051
I didn't see AT in that one. I'm not that up on AT I use lua It's easy and works with a lot less work.
I had the AT firmware downloaded some where I played with it then loaded Lua back.
 

Thread Starter

mkbutan

Joined Sep 30, 2008
296
hi
in all the documents on the net one thing is common " Upload the Latest Firmware " for better use which is as on Today(15.08.2016 / 0130 IST) 1.5.4.1-master_20160802 from
https://github.com/nodemcu/nodemcu-firmware/releases ........
now can any one tell me How to upload the 1.5.4.1 - Master_20160802 the Latest Firmware to ESP8266 ESP-12e NodeMCU Module.

The NodeMCU Module is working for ARDUINO IDE Examples Code in it but not responding to the AT Commands in the ARDUINO IDE Serial Monitor Terminal...

I wanted to Communicate two or more ESP8266 in Network (Mesh Network) and to be Controlled by PC/Mobile through Internet.....

Thanks
 
Last edited:

be80be

Joined Jul 5, 2008
2,051
Well thats great but you get no AT commands
WHAT you posted doesn't have AT commands don't believe me.
Good luck
 
Last edited:

Thread Starter

mkbutan

Joined Sep 30, 2008
296
Hi Dear Sir, Thanks for you Time given to me...
I wanted to Communicate two or more ESP8266 with Some Sensor in Network (Mesh Network) and to be Controlled by PC/Mobile through Internet.....
What should I do to make it Working. ..
I have Two Pare of ESP 8266 ESP-12e NodeMCU
 

Attachments

Top