Couldn’t find board on selected port

Thread Starter

navyguy

Joined Sep 27, 2019
103
Hi.
now onto my second problem.
tried uploading my program onto my arduino micro and it says that it can’t find the board on the selected port.
The port option on the tool bar is grayed out. Ideas anyone?
thanks so much.
 

trebla

Joined Jun 29, 2019
215
Usually, if USB port is not recognized, try to change the connection cable. If it does not solve the problem, go to Control panel and check COM ports appearing/disappearing if you connect/disconnect board. If COM port appears by connecting the board but Arduino IDE does not recognize port then try to reinstall Arduino drivers.
 

Thread Starter

navyguy

Joined Sep 27, 2019
103
Usually, if USB port is not recognized, try to change the connection cable. If it does not solve the problem, go to Control panel and check COM ports appearing/disappearing if you connect/disconnect board. If COM port appears by connecting the board but Arduino IDE does not recognize port then try to reinstall Arduino drivers.
Thank you so much for the info. I did try swapping cables because this happened before. No luck.
 

trebla

Joined Jun 29, 2019
215
If COM port does not appear in your computer Control Panel then :
A) bad device (Arduino), either bootloader or hardware fault
B) bad USB cable
C) bad USB port on your PC
D) driver issues in your PC

If you connect Arduino to PC, does the PC sense anything by connecting it (mouse, keyboard or unknown device)?
 
Top