Copper zones not filling in KiCAD 8

Thread Starter

Vilius_Zalenas

Joined Jul 24, 2022
174
Hi,

I am not a complete beginner with PCB design, but using KiCAD for the first time. I am doing a 4 layer board with 2nd and 4th being the grounds. I made a copper zone on the second layer (for now its the only zone on the whole board, so priority does not matter), assigned the GND net to it and pressed "B", but the zone did not fill. I have already searched for an answer in the forums, but all the solutions suggested earlier did not work for me. What is causing the copper zone not to fill?
 

Attachments

MaxHeadRoom

Joined Jul 18, 2013
28,761
Control B
B
Toggles the fill- No fill option.
Look at the list of hot keys, ensure the keys are set, they are close to the bottom of the list, you can also set your own.
 
Last edited:

Thread Starter

Vilius_Zalenas

Joined Jul 24, 2022
174
Press “b” to refill zones, or is it control B.
Also there is one more thing I can get over with on my own. Somehow there is this pad exclusion zone set around each pad that prevents any coper other than the dedicated net to be in specific range of the pad. I tried to find how to reduce this distance really hard but could not find how to do it, the internet did not help either. Do you know how can I reduce the pad exclusion zone?
 

Attachments

ronsimpson

Joined Oct 7, 2019
3,134
I don't have CAD on this computer but, from memory, select the coper fill and edit or change properties. There should be clearance numbers to change. Clearance just in that coper and not others.
 

Thread Starter

Vilius_Zalenas

Joined Jul 24, 2022
174
I don't have CAD on this computer but, from memory, select the coper fill and edit or change properties. There should be clearance numbers to change. Clearance just in that coper and not others.
Ok, I managed the net exclusion zone problem, but the problem with copper fill persists. I have checked my hotkeys and watched many tutorials, I am doing the exact same thing. I even get loading screen for some short period when I press ,,B", but there is still no fill. Are there any graphical or project related settings that are likely to cause this problem? I tried to do it with different nets and on different layers, but result was the same...
 
Top