Bluetooth problem in ESP32

Thread Starter

sarose

Joined Mar 9, 2020
1
I have used 5 Oled for displaying 5 different sensor values in esp32 devkit. It was working fine but when i wanted to use bluetooth, one Oled which is connected to GPIO pins 01 and 03 is not working and other 4 Oled are working. If i keep bluetooth code that oled wont work and if i again dump another code which donot include bluetooth then all oled is working. Why it is happening? What may be the problem?
I have shown pins that i have used for Oled(SDA , SCL) and Sensors(S0-S4) in image below.
 

Attachments

ErnieM

Joined Apr 24, 2011
8,152
Those pins are also for an I2C interface and a serial date interface as well. WQithout diving into the 1,000's of pages of the ESP spec I would just assume the BT is hijacking those pins for some other function, so I would put those LEDs on other pins and see if my mileage varies.
 

djsfantasi

Joined Apr 11, 2010
7,693
Those pins are also for an I2C interface and a serial date interface as well. WQithout diving into the 1,000's of pages of the ESP spec I would just assume the BT is hijacking those pins for some other function, so I would put those LEDs on other pins and see if my mileage varies.
In general, a common mistake with microcomputers. Takes some extra effort that’s not optional. Take an inventory of all the pins you want to use and that are needed by other peripherals and used by the development board for other purposes... And make sure there are no conflicts. Applies to any microcomputer solution.
 
Top