Bluetooth problem in ESP32 ..#2

Thread Starter

roselewis

Joined Jun 19, 2022
4
I have used 5 Oled for displaying 5 different sensor values in esp32 devkit. It was working fine but when i wanted to use bluetooth, one Oled which is connected to GPIO pins 01 and 03 is not working and other 4 Oled are working. If i keep bluetooth code that oled wont work and if i again dump another code which donot include bluetooth then all oled is working. Why it is happening? What may be the problem?
I have shown pins that i have used for Oled(SDA , SCL) and Sensors(S0-S4) in image below.
epoxy flooring Salt Lake City
I have used 5 Oled for displaying 5 different sensor values. It was working fine but when i use bluetooth, one Oled which is connected to GPIO pins 01 and 03 is not working and other 4 Oled are working. If i keep bluetooth code that oled wont work and if i again dump another code which donot include bluetooth program then all oled is working. Why it is happening? What may be the problem?
I have shown pins that i have used for Oled(SDA , SCL) and Sensors(S0-S4) in image below.

Mod:Link to old thread.

https://forum.allaboutcircuits.com/threads/bluetooth-problem-in-esp32.176669/post-1600111

ATTACHMENTS
ESP32-DOIT-DEVKIT-V1-Board-Pinout-30-GPIOs-Copy.png
ESP32-DOIT-DEVKIT-V1-Board-Pinout-30-GPIOs-Copy.png (140.32 KiB) Viewed 830 times
 
Last edited by a moderator:

KeithWalker

Joined Jul 10, 2017
2,453
If you look at your pin-out diagram you will see that GPIO1 and 3 are also used as UART TX and RX. These are the pins that are used for serial I/O and for communicating with the Bluetooth device. To get it working, you must re-assign the OLED pins.
 
Top