Bike computer display problem!!!!

Thread Starter

SamiBouterra

Joined May 29, 2020
3
Hello everybody,
I am new here and don't have much experience with circuits and I have a problem with my bike computer:
Water got inside of it took the battery out opened it and let it dry for days after I unscrewed the board.
I replaced the battery with a new one and I can see numbers shown on the screen but not completely, when I turn the wheel the speed changes but the problem is that I have '' half numbers shown on screen"
I have no idea where to start and if it will require a soldering iron!!
So HELP!
Attached is the computer manual
 

Attachments

Delta prime

Joined Nov 15, 2019
336
The instruction manual says it has a 2 year warranty. You should try that first but if not you're going to have to open the whole thing up and take lots of photos they are not made to be serviced. :)
 

AlbertHall

Joined Jun 4, 2014
9,873
This sounds like the connections to the display not connecting correctly. Is the display connected by a flexible PCB strip, or an elastomeric strip?
 

Thread Starter

SamiBouterra

Joined May 29, 2020
3
Hello AlbertHall and Dodgydave I think the display is connected by an elastometric strip : so if I should clean it what part should I clean and using what?
Attached are two pictures of the computer board and display.
Thank you.
 

Attachments

Dodgydave

Joined Jun 22, 2012
9,162
On the jpg.2 the top gold connections in a row, and the Black rubber strip at the bottom of the LCD, use isopropyl alcohol,or glass cleaner with a soft brush or cotton ear bud.
 
Top