AVR - Failed to enter programming mode.

Thread Starter

TheCircuitsHaveEyes

Joined Mar 19, 2016
16
First off, let me just say that I'm a beginner in microcontrollers. I haven't even used Arduino. So please keep that in mind when giving solutions.

I'm using an ATMega16A in conjunction with Atmel Studio 7 and an Olimex AVR ISP MKII.

The first time I tried the "Blink" program, it worked. However, now(a few weeks after test) it just won't enter programming mode. I go to Tools->Device Programming, where it shows that it knows the device name, the programmer as well as the interface. It doesn't know the device signature(if I click read I get the error in the title). If I click read on Target Voltage, it says 3.3V even though I'm powering it with 5V.

Since the first successful try, I've only added some bypass caps and a 5.6V Zener on the power rails.
 

dannyf

Joined Sep 13, 2015
2,196
It could be a wiring problem. Or you could have accidentally programmed the reset bit, or a faulty programmer or programming software, .....

Just need to go through a process to eliminate false positives and isolate the root cause.
 

Thread Starter

TheCircuitsHaveEyes

Joined Mar 19, 2016
16
What do you mean by programming the reset bit? The only reset I know is a pin and it needs to be connected to the programmer.

As for wiring, it goes like this:
- Pins 11 and 31 -> GND
- Pins 10 and 30 -> VCC
- The 6 programmer pins to the corresponding uC pins
 
Last edited:
Top