ATMega328 powered clock - outputs stop displaying

Discussion in 'Embedded Systems and Microcontrollers' started by Darren Midkiff, Jan 7, 2016.

  1. Darren Midkiff

    Thread Starter New Member

    Jan 5, 2016
    I am following an instructable to build a clock that displays the time in English words using LEDs. The output of the circuit is controlled using 3 8 bit shift registers and 3 transistor arrays. I am currently testing the circuit using a breadboard and LEDs. I have attached the schematic from the instructable and my modification of that schematic to use the 74HC595 registers I had available instead of the HCF4094s used in the instructable as well as the Arduino code being used.

    Whenever the minute indicator should move from "QUARTER" to "TEN" all LEDs turn off and the circuit does not resume functioning unless I unplug it for about a minute and plug it back in.

    Troubleshooting so Far
    • I have tested the code using an Arduino Nano connected to 3 shift registers with LED outputs with no issue. The clock worked for all times.
    • By default, the clock begins at "HALF PAST NINE". Using the hour and minute increment buttons, I can cycle through all hours successfully; however, when attempting to cycle through minutes the device ceases to function when I try to increment from "QUARTER TO [hour]" to "TEN MINUTES TO [hour]". Leaving the clock to change time on its own yields the same result. When it should move past "QUARTER" all LEDs turn off.
    • I have checked for voltage across the OE' pins after the LEDs turn off. It is a low signal (.1/.2 V).
    • I made and ran a program that clocks the registers and sends a 1 to the Data lead every 8 clock cycles. This lead to the discovery of some wiring issues and fixes, but revealed nothing in regards to the issue above.
  2. ebeowulf17

    Distinguished Member

    Aug 12, 2014
    Just to clarify, did you connect this Nano to the same clock rig (shift registers, LEDs, etc.) that's failing with your stand-alone 328, or another set of shift registers and LEDs?

    If it's the first situation, that would seem to indicate that all of your other wiring and your code are good, and that the problem is either the 328 or the extra components/wiring that it requires (oscillator, etc.) Not sure what could be wrong on this end, as I'd expect any mistake here to be all or nothing, not successful operation until a certain point in the code.

    If it's the second situation, then all you've really established is that the code works on a 328 chip and that your problem is somewhere in the wiring/hardware. You'd have to try isolating, replacing, or removing different components to try to narrow things down some more.

    This is an interesting problem. I'd love to hear how it turns out. (Or turned out if you've already found the solution before I replied.)
  3. Darren Midkiff

    Thread Starter New Member

    Jan 5, 2016
    I connected the Nano to a different set of registers. It must be a hardware issue with the soldered protoboard I put together, but I cannot seem to find any wiring issues. It is a nasty, messy, crowded board, though. Next project, I'm going to try to learn etching. using solderable protoboard is proving difficult.

    I was in a hurry to finish when I started and just put the whole thing together without incremental testing, so now I'm paying for it. I've actually decided to rebuild. I had all the components I need except one transistor array, so I pulled one off of my previous board (huge pain, but thankfully no heat damage). I just breadboarded all the components to test and it is working. Now to move it slowly and carefully to the protoboard like I should've done in the first place.