Unknown USB Device error (STM32F412 virtual com port using CUBE MX functions) Windows 10

Thread Starter

zazas321

Joined Nov 29, 2015
432
Hey. I am trying to interface with the USB but I am having troubles with my PC recognising the device.
The schematic I use:
upload_2019-10-15_12-44-8.png

USB data lines directly connected to microcontroller and a pullup on D+. Initially, I have tried to get it working without 1.5k pullup on D+ but my PC did not react to the USB plugged in at all ( It did not show up in device manager at all not even with an error message and I could not hear USB sound that you usually hear when you plug something in).

When I added 1.5k pull up, the pc can recognise that there is something plugged in but I am getting an error:


upload_2019-10-15_12-46-55.png


Most common solutions I have tried:

1. Unplugging PC power cable whilst the USB is plugged in and resetting the PC to refresh the drivers

2. Updating Generic USB drivers

3. Disabled USB selective suspend setting

4. Deleted the corrupted device and drivers from the device manager and then plugging in the device again

5. Downloading various types of drivers even though I should not need any drivers for windows 10 VCP


I am able to plug in some other STM devices through UART interface to my PC and see the com port with no trouble therefore I believe there must be some hardware problem though I cant figure what could be wrong as this is as simple as it gets.


In terms of code, I have just generated a cubemx project , set up my USB device only as VCP (virtual com port) and in my main.c just calling the function MX_USB_DEVICE_Init(); which I assume should handle the rest.

Any ideas or suggestions are appreciated!
 

Attachments

Top