RN4020 1.2 firmware MLDP

Thread Starter


Joined Jan 4, 2011
Hello everyone. I am using the RN4020 bluetooth module from microchip to send data from and to my phone. I am using the mldp mode, where the module acts like a serial bridge between the phone and the microcontroller.
I was using RN4020-V/RM, which has firmware 1.1 and everything was working correctly. Now I bought the module RN4020-V/RM120, which has firmware 1.2. With this new firmware I can't send data from my phone to microcontroller, only from the microcontroller to the phone.

Using an application from nordic, I was able to get the characteristics used by the module and noticed the some were added from firmware 1.1 to 1.2. I am attaching the screenshots from the app.
I already tried changing the Write Type to Write Request but no luck.

The configuration I use for the SR register in the module is: SR,38004C00
This worked with version 1.1, but with 1.2 I can only receive on my phone and not send to the micrcontroller.

Has anybody worked with these modules and knows what changed from 1.1 to 1.2 in the MLDP mode and how I can get it to work again?
Thanks in advance.