Problem in programming a MSP430 MicroController

Discussion in 'Embedded Systems and Microcontrollers' started by Omer Dagan, May 1, 2018.

  1. Omer Dagan

    Thread Starter New Member

    Dec 4, 2016
    23
    0
    Hello ,

    I'm using MSP430F5131 Microcontroller of TI.
    I also use a MSP-FET Emulator in order to program that device.
    i have written a code in Code Composer Studio (Defined the properties of CCS's project to the devices im using).
    I compiled the program and no errors has found.
    Then i connected the MSP-FET to the board according to the datasheet SLA138H , page 26 . (The board supplies the 3.3V so i connected it to pin 4 in the JTAG connector of the MSP-FET). I didn't connect the TEST/VPP and didnt connect the the resistor R2 330Ohms as instructed in that datasheet coz i dont need to use the fuse blow protection functionality.

    My problem occurs when i try to download the program to the MSP430 device , when i hit on the downloading button an error message pops up :
    "Error connecting to the target: Unknown device".

    I tried to do the same in IAR Embedded Workbench (Same code , same properties) it asks me to update my firmware of the MSP-FET i click ok and it updates the firmware , but then i get the same error as i have got in the Code Composer Studio :
    "Tue May 01, 2018 11:08:46: Fatal error: Could not find device (or device not supported) Session aborted! "

    It is needed to be said that when i hit on the download button the "MODE" red led on the MSP-FET flashes and then stays on after the error message has been popped.

    I tried to get the 3.3V supply voltage for the downloading purposes from the MSP-FET (JTAG pin 2) and it still doesn't work and get the same error.

    I also made sure that the MSP430 gets the amount of voltage its needed (3.3V from the board by a regulator).

    I would like to know how i can solve this problem and download my code into the MSP430.

    I have attached a wiring schematic of the board. hope it will help.

    thanks in advance.
     
Loading...