Oscilloscope Wave for PWM Signal

Thread Starter

Lesliev

Joined Jan 13, 2021
11
Hello, I am new to this forum and still learning about some aspects of electronics. I have purchased and installed a USB oscilloscope and am trying to learn how to use it one step at a time. I have set up an Arduino Uno with a PWM sketch to cause an LED to pulse. That part works just fine. However when I connect my Oscilloscope I get a wave form like the one shown in the attached file. As a complete newbie to the oscilloscope I am trying to understand why I am not getting the square waveform I was expecting. I dont know if it is the oscilloscope, its settings or the Arduino setup I am using which is pretty much a very standard setting as is using the basic Fade sketch available in the Arduino GUI I am using.
Sure hope someone can help as I have tried everything and just keeping get ting further lost
 

Attachments

Thread Starter

Lesliev

Joined Jan 13, 2021
11
OK after posting I then ran through my very simple setup again and found I was not connecting the probe correctly. Obviously something I should have done before posting a request for help so my apologies for a pointless post. Now, with the correct connections and input from hexreader I am seeing a square wave as expected and now just have to work out how to adjust the Oscope to get a clean wave.
Sure is lots to learn with the Oscope but a great deal of enjoyment doing it.
 

dl324

Joined Mar 30, 2015
12,678
Welcome to AAC!

Now, with the correct connections I am seeing a square wave as expected and now just have to work out how to adjust the Oscope to get a clean wave.
Show us the wave form and settings for vertical amplifier and timebase.
 

Thread Starter

Lesliev

Joined Jan 13, 2021
11
You guys and gals are incredible. So much help and so helpful.
I have attached the latest screen shot of the Oscope and any advice would be so welcome. I do live in Australia and I believe that we do use 50Hz power her but to pick up on that is amazing. As I said you guys and gals are amazing.

Should I post full image or thumbnail??
Waveform-2.jpg
 
Top