Onkyo TX NR545 reciever no power

Thread Starter

Sharpen047

Joined Apr 19, 2012
51
Hey guys, so i have my receiver here that doesnt power on at all, no relay click either. fuses are good but not sure how to proceed.
Here is the service manual.
https://www.manualslib.com/download/1383872/Onkyo-Tx-Nr545.html
i test p9011b for power and it has 12v at pin 4 as it should while in "standby".
i test for 3v on pin 3 and it shows 12v which is obviously wrong.
there is no power from the power supply to the transformer (because the relay isnt being switched on?)
i guess i need to find out what tells the relay to power on.
any help would be appreciated! thanks
 

dendad

Joined Feb 20, 2016
4,504
Do you have 12V on P9100A pin1 (page 42)?
Pin 3 should be your reference point. What are you using?
Check the solder joints around the pins.
You can ground pin 1 ( to pin 3) and turn the relay on.
 
Last edited:

Thread Starter

Sharpen047

Joined Apr 19, 2012
51
there is no P9100 in the document, am i missing something?
turning the relay on doesnt power the unit on either. relay clicks but 10 watts of draw at the wall.
 

Thread Starter

Sharpen047

Joined Apr 19, 2012
51
ok so i found out why it stopped powering on to begin with. my plate amp on my jbl sub blew some capacitors and shorted the output on the sub out. there is a 100 ohm resistor that blew, shorting to ground. replaced the resistor and replaced the plate amp with a spare and everything works as it should. thanks for the help
 
Top