My Windows 7 computer somehow gets updated even though I have turned off updates

Thread Starter

whitehaired novice

Joined Jul 15, 2017
289
My Windows 7 computer fails after updates so I have turned them off. That worked for several years, but recently about once a month, an update gets through and the next morning my computer won't work till I have resumed to an earlier date. Is there a way to make sure that updates don't get through?
 

mvas

Joined Jun 19, 2017
538
There are 6 editions Windows 7 ... Starter, Home Basic, Home Premium, Pro Enterprise & Ultimate ...
Which edition to you have?
 
Are you using something like McAfee that is set to update?

Edit. Maybe n/m seems that Windows can update whether you tell to or not (see below). Maybe select tell me, but let me update?

Update1.jpg
 
Last edited:

Thread Starter

whitehaired novice

Joined Jul 15, 2017
289
Well, I may regret this, but another google search led to a suggestion to delete Microsoft Security Extensions (I think that's what it was called).
So I did. No apparent harm yet. I'll keep you posted--unless my computer never starts again.

Bye the way, apparently there are LOTS of us with this problem.
 

JohnInTX

Joined Jun 26, 2012
4,380
FWIW, my Win7-64 Pro system sometimes chokes on updates due to other processes running. If your basic problem is that updates fail requiring long restore times and you want to fix that you can shut down those other processes, let Windows update then turn them back on. Here is one procedure to do that.

Caveat: this comes from Microsoft and works for me. Be sure your files are backed up and you have a system restore disk in case things go south due to malware, incompatibilities or something else that would cause a crash.

Close any open files.
Click the START button
In the Search Programs and Files box type msconfig and hit return.
Click the 'Services' tab.
Check the box 'Hide all Microsoft services'. What's left is everyone else.
Click Disable all
Click Apply.
Click OK to Restart the computer.

When it's back , fire up Control Panel and perform the update process manually (System and Security -> Windows Update -> Check for Updates)
Let er rip.
Hopefully, the updates will install normally.
Reboot.

Go back into msconfig.
Click the Services Tab
Click Enable All to restore the active system services.
Click Apply
Click OK to Restart.

That's what I do. Otherwise, like you have found, the persistent updates can be a pain.

Good luck!
 

Glenn Holland

Joined Dec 26, 2014
705
Immediately after you start your computer, open the following:
Task Manager
Resource Monitor - CPU Tab
You should see the screen below
:


Then look at the "Services" Box. Where it says "wuauserve". Right click on it and you will see a box that says "Do you want to suspend suspend wuauserve.

Click yes. Then it should indicate "stopped". That will shut off any updates during the particular session your computer is up and running. However, you must repeat this procedure every time your start your computer.
 

Thread Starter

whitehaired novice

Joined Jul 15, 2017
289
Well, deleting Microsoft Security didn't work--Microsoft just reinstalled it.

But, thanks to others I found out what to do. Control Panel/Administrative tools/services/ find updater and disable.

That seems to have worked but I'll update this if it doesn't.
 
Top