Looking to repair Wii U gamepad power supply.

Discussion in 'General Electronics Chat' started by tron999, Dec 30, 2015.

  1. tron999

    Thread Starter New Member

    Dec 30, 2015
    Hello there,

    I hope I'm posting this on the right forum. I have a Wii U, which comes with a charging stand for the gamepad. Recently, this stand no longer charges the gamepad. I put a multimeter on the stand's connectors, and it had no voltage.

    Here's a couple pictures of what's in the charger. Where do I start looking for something that's broken? I already bought a new one, so there's not a big rush on this, but I thought it would be cool to try and fix it.


  2. SLK001

    Senior Member

    Nov 29, 2011
    You're going to have to post better pictures if you want any help. You're also going to have to remove all that white staking compound, so that all the components can be identified.

    What is the DC voltage on the large cap on the input side? Also, why isn't your location shown?
  3. bwilliams60

    Well-Known Member

    Nov 18, 2012
    Yes better pictures straight on from the top and bottom and then some good pictures angled from the sides would be good. Nice and clear. Ditto on the cap voltage and be careful, enough there to kill you. If not sure, then leave it alone. Give it to a professional.
  4. sailorjoe

    Active Member

    Jun 4, 2013
    That white thing on the right side edge of the board looks like a fuse. Unplug the entire unit, and measure the resistance across the pins under that part. If my assumption is correct, you should see near zero resistance. If you get an open circuit, then the fuse is blown. Now we have to figure out why. DO NOT PUT A SHORT CIRCUIT ACROSS THE FUSE. FIRE HAZARD. And it could do more harm to your circuit board.
  5. AnasMalas


    Nov 27, 2015
    Had one charger that no longer worked, i tried everything to get it fixed. Nothing...
    After i bought a new one i realized that i didnt see if the board is even receiving voltage. sure enough it wasnt! turns out one of the wires inside the plug got loose...

    My suggestions(extra detail included):
    measure the voltage across where the mains cables are attached. Make sure that: You use a proper safe multi meter(10$ multimeters with "High Voltage" are just there for natural selection. dont be a part of it), Make sure your selection in Volts AC and that the lead is in the voltage socket (between current and common is a dead short, another instance of natural selection), Be insulated from ground (surprisingly enough, the floor conducts electricity! W. O. W.) and dont touch the metal...

    All that done? If you read that there is a voltage that is just like that of the socket, go on. if not(No voltage or a low value, such as 60 in USA or 150 everywhere else), thats your problem.
    Now that you have a correct voltage, leave the thing for a couple of hours for the discharge resistor to do its job. that black cylinder is a capacitor, And believe me its full of "surprises" unless it contains no charge. discharging with a screw driver is natural selection, again...

    After that start probing around. check the fuse, it shows a low resistance? move on.

    Finally the last thing in my personal experience (when you cant see nothing burned down, its harder...) is to check for a short across the charger wires, and then check that the wires reach to the port and are not broken somewhere in between....