Logitech z533 problem turning on

Thread Starter

biso95

Joined Mar 2, 2020
1
I have a 2.1 speaker from logitech, model z533. When I try to turn it on, it keeps to be off and when I try to lower the volume it turns on around level 0, right when it's near the power off. If I try to raise the volume it goes off again.
It could be a potentiometer problem or what? I've tested it and it goes 0-12kOhm and then drop down to 2KOhm, is it normal?
Here some images of the pcb if needed.
photo_2020-03-02_14-30-36.jpgphoto_2020-03-02_14-30-33.jpg
 

gravmanx76

Joined Jul 3, 2020
2
[QUOTE = "DarthVolta, message: 1528245, membre: 260907"]
"Bonjour j'ai le même problème, je ne comprends pas votre réponse merci"

OP dites-vous qu'il n'y a pas de volume ou qu'il est en train de s'éteindre?
[/CITATION]
Qu tourne un peu j'ai la lumière blanche et ensuite plus rien
 

Daspolo

Joined Sep 23, 2020
1
Hi,
Three months ago, I have broken the potentiometer of Logitech Z533 speakers. I tried to do a bridge between the two central point (look at the image), and It work.
Now, after three months, the speakers are again break.
I tryed to remake the bridge, but the don't want to work anymore, the speakers doesn't switch on.
Have you any idea?
Thank you, and sorry for my bad English, I'm italian.
 

Attachments

Viktor_Ip

Joined Sep 25, 2020
1
Hello there. Mine is broken too. Good to know that I am not the only one. It´s a weak product. I need to replace the potentiometer. Does anyone have any information about technical data? Ohm? Biso95 says 12K - can anyone confirm this? I cannot measure it, because it´s broken. Is it logarithmic?
 

Shake97

Joined Oct 11, 2020
1
He'llo I recently have ran into this problem as well the speakers will not turn on unless it's is at the very point before it is suppose to switch off , I have no idea about electronic's is there anyone that knows how to repair this or if there's a simple fix even a monkey could do?
 

Viktor001

Joined Oct 28, 2020
1
Hello there. Mine is broken too. Good to know that I am not the only one. It´s a weak product. I need to replace the potentiometer. Does anyone have any information about technical data? Ohm? Biso95 says 12K - can anyone confirm this? I cannot measure it, because it´s broken. Is it logarithmic?
Same problem here i broke it while trying to clean it because of the cracking any information of it value and maybe some link where to buy it online in my country there aren't potentiometer like this
 
My speakers have the same issue - they turn on at volume 0 but if this is raised the LED flips off and the speakers turn off.
I'm going to attempt what oguafsdf suggested later:

"In my case it's the on off switch under the poti. If you solder it out it's just a peace of metal which has lost tension pressing against the other one, just bend it a little bit."
 

djsfantasi

Joined Apr 11, 2010
8,578
[QUOTE = "DarthVolta, message: 1528245, membre: 260907"]
"Bonjour j'ai le même problème, je ne comprends pas votre réponse merci"

OP dites-vous qu'il n'y a pas de volume ou qu'il est en train de s'éteindre?
[/CITATION]
Qu tourne un peu j'ai la lumière blanche et ensuite plus rien
Hi!

This is an English language site. Please use an online translation tool to reply in English.
 
Just wanted to leave an update, bypassing the on/off switch on the potentiometer totally works. The volume control still works too, the only difference is that if you swivel it to 'off' the speaker remains on. A fair concession!!
 

Huffington

Joined Feb 26, 2021
2
Hi,
Three months ago, I have broken the potentiometer of Logitech Z533 speakers. I tried to do a bridge between the two central point (look at the image), and It work.
Now, after three months, the speakers are again break.
I tryed to remake the bridge, but the don't want to work anymore, the speakers doesn't switch on.
Have you any idea?
Thank you, and sorry for my bad English, I'm italian.
Mate, why did you brake it :( there were screws waiting for you to unscrew... anyways, seems like your cables are broken, especially the yellow one. you might want to check them on the other hand the solution is worked like a charm! I made a bridge with a cable with a clean finish.
 

Huffington

Joined Feb 26, 2021
2
My speakers have the same issue - they turn on at volume 0 but if this is raised the LED flips off and the speakers turn off.
I'm going to attempt what oguafsdf suggested later:

"In my case it's the on off switch under the poti. If you solder it out it's just a peace of metal which has lost tension pressing against the other one, just bend it a little bit."
I soldered the on/off button which avoids future problems :) but thanks, your method is also working but for a super short of time :)
 
I have same problem with control pad. When volume 0, power is existing but when increase volume power is not existing. I tried to fix this problem but I cound't dismantle the part of volume control circle. How can I dismantle this part?WhatsApp Image 2021-03-08 at 15.44.33.jpeg
 

0x10001

Joined Apr 15, 2021
2
I have same problem with control pad. When volume 0, power is existing but when increase volume power is not existing. I tried to fix this problem but I cound't dismantle the part of volume control circle. How can I dismantle this part?View attachment 232275
You can just pull up on the disk, it is not screwed, but to solder the 2 points you need to remove the bottompart, peel of the rubbery part to reveil the 3 screws.
 
[QUOTE = "YesMySelecta, publicación: 1593513, miembro: 761516"]
Solo quería dejar una actualización, omitir el interruptor de encendido / apagado en el potenciómetro funciona totalmente. El control de volumen también funciona, la única diferencia es que si lo gira para "apagar", el altavoz permanece encendido. ¡¡Una concesión justa !!
[/CITA]
how do you do that?
 
Top