Logitech Z323 preamp board damaged..

Thread Starter

itshams

Joined Jan 30, 2021
3
Hi guys, this is my first post however I really want to get this fixed.

My Logitech Z323 speakers (right, left speakers and 1 subwoofer) preamp board got damaged and I'm searching for a replacement but I'm not 100% what I need to fix this.

I'm attached some photos of what the preamp board looks like:

20210130_170111.jpg

20210130_170103.jpg

20210130_170059.jpg

20210130_170055.jpg

Any help would be very much appreciated.
 

Thread Starter

itshams

Joined Jan 30, 2021
3
The parts are broken I could try and replace them e.g. a new 3.5mm stereo jack socket and a volume control knob
 

Dodgydave

Joined Jun 22, 2012
9,951
Looks like a dual gang volume control , there will be a value stamped on the side somewhere, take a closer photo.

The jack socket maybe ok it seems the shroud is broken.
 

Thread Starter

itshams

Joined Jan 30, 2021
3
Thanks for your reply, yes I see B50K, also it's an 8-pin potentiometer.

I'll desolder and replace this and see if this fixes it:)
 

eyemtryin

Joined Mar 28, 2021
1
Hi guys, this is my first post however I really want to get this fixed.

My Logitech Z323 speakers (right, left speakers and 1 subwoofer) preamp board got damaged and I'm searching for a replacement but I'm not 100% what I need to fix this.

I'm attached some photos of what the preamp board looks like:

View attachment 229091

View attachment 229092

View attachment 229093

View attachment 229094

Any help would be very much appreciated.
Hi itshams. I am currently attempting repairs to my z323 system with the same pcb, different issue. I was hoping i could ask you for assistance with mine. Those photos are perfect, would you be willing to post a couple of the back side so I can repair burned traces on my board? I really appreciate it!! thank u so much :)
 
Top