Issue with CD4026 Real World Implementation

Thread Starter

cakarertugrul

Joined Jan 27, 2021
6
Hi everyone, This is my homework. I have to do heartbeat monitor and it needs to count up to 99 then stays. I designed the circuit and simulated works perfectly. I used Proteus software for the simulation, but in Proteus CD4026's Carry Out (5) pin is only 0 at 9 so I designed for this situation to detect 99 as you can see from schematic. But I have CD4026BE in circuit implementation and its datasheet says Carry out pin is low at 5-6-7-8-9 counts then I tried to detect 9 from decoder parts (A-B-C-D-E-F-G) to detect 99 but whenever I connect the output of decoder parts with AND gates (CD4026- A-B-C-D-E-F-G) displays are turning off due to low voltage output. I thought I need to use OPAMP for amplification the voltage but it didn't worked aswell. Can you help me please? btw In the first version of the implementation it is working but stays at 55 because carry out pins are low at 55. Second screenshot is for U3:B in first schematic. I tried to sense 99 from decoder outputs.
 

Attachments

Thread Starter

cakarertugrul

Joined Jan 27, 2021
6
I used 9V battery, also I used Power supply for different voltages, I applied 5V to 9V. Increased 1V step by step but it didn't worked aswell. I am using TTL IC types.
 

dl324

Joined Mar 30, 2015
12,871
I used 9V battery, also I used Power supply for different voltages, I applied 5V to 9V. Increased 1V step by step but it didn't worked aswell. I am using TTL IC types.
You can't use a 9V supply with TTL.

TTL outputs aren't guaranteed to drive CMOS inputs. CMOS outputs can drive TTL, but fanout is low.
 

Thread Starter

cakarertugrul

Joined Jan 27, 2021
6
Many thanks, I appreciated it. Do you have any suggestion for changing CD4026 to TTL match of it? or you suggest me to change other ICs to CMOS?
 

crutschow

Joined Mar 14, 2008
27,198
Many thanks, I appreciated it. Do you have any suggestion for changing CD4026 to TTL match of it? or you suggest me to change other ICs to CMOS?
I would suggest changing all ICs to CMOS.
You can use the 74HC versions of the gates to avoid having to rewire anything, but they operate at a maximum of 6V (5V nominal).
 

Thread Starter

cakarertugrul

Joined Jan 27, 2021
6
I changed them with 7408 AND and 7404 Inverter gates but it is not working still I think I need buffer at the outputs of the CD4026.

I read 2.5V at the input of AND Gates when it should be high that's my problem for now :( I will try to use buffer or double inverter.
 

dl324

Joined Mar 30, 2015
12,871
I read 2.5V at the input of AND Gates when it should be high that's my problem for now :( I will try to use buffer or double inverter.
A HIGH output from TTL can be as low as 2.4V. CMOS inputs must be at least 3V (when operating at 5V) to be recognized as a logic HIGH.
TTL specs:
clipimage.jpg

CMOS (CD4026):
clipimage.jpg

If you don't know what you're doing, you shouldn't mix logic families.
 
Top