Help about drone

Thread Starter

Dzoro

Joined Feb 1, 2019
194
So me and my friend were flying the drone the drone is dji mavic pro and we crashed it into a wall and when i opend it i saw that the flat cabel for the 3 axys on the gimbal(camera) has broke in half and we found it on the amazon for around 40 euros and when it came we put the new cabel, power up the drone and on the remote is saying gimbal overloaded and the camera is going crazy for 10 to 15 seconds and stops and about 30 seconds after, it goes crazy again
I have searched the internet and the only thing that i found is that to put the drone side way and power it up but that didnt work so it will be realy helpfull if someone had that expereience and share it how he fixed it beacose the cabel is expensive and we need to wait about 2 months to arive and to send it to the dji its more expensive because of the shipping and the cost of the repair so if anyone has an idea how to fix it, it will be really greatfull
Thanks Dzoro
Ps:sorry for my english
 

drc_567

Joined Dec 29, 2008
1,154
Is it possible to 'reset' the drone electronics somehow? Maybe you could remove the batteries for a minute or two to accomplish this. ... Also be sure that any new connections are thoroughly clean ... suggest using electrical contact cleaner if you can obtain some. There could possibly be a layer or film of some sort on the metal surfaces of the new cable.
 

Thread Starter

Dzoro

Joined Feb 1, 2019
194
Is it possible to 'reset' the drone electronics somehow? Maybe you could remove the batteries for a minute or two to accomplish this. ... Also be sure that any new connections are thoroughly clean ... suggest using electrical contact cleaner if you can obtain some. There could possibly be a layer or film of some sort on the metal surfaces of the new cable.
I have 98 percent isopropyl alcohol i clean potentiometers with it and it works i will try that
 

Thread Starter

Dzoro

Joined Feb 1, 2019
194
I did all the things from above and none of them were working i cleaned the contacts i cleaned the gimbal i reatached everything and still the same thing happen and the camera goes very hot after 3 or 4 times of restarting
 
Top