Head Light Bulb Kit and Li-Ion Battery Pack

Thread Starter

ilginsarican

Joined Jul 13, 2017
106
Hello,
I have lithium-ion battery pack that consists of 21 cells( 3 parallel,7 series,one of them 4,2V 3.4Ah).
I use this battery pack with BQ7791504PW from Texas Instruments for battery protection.This IC achieves pack protection via CHG and DSG low-side NMOS FET drivers.
I use this battery pack for feeding car headlight Bulb kit.
The input voltage of bulb kit is between 16-32VDC and the output is 85V,35W.
I guess there is ballast circuit in the kit to feed headlight Bulb.
The problem is when I give energy from battery pack(PACK+ and PACK-) to the kit, I measure high voltage oscillation on "PACK+".
You can see the measurement result in the attachment.
I think the ballast circuit in the kit causes this high voltage oscillation.
To solve this, I used SMAJ30A TVS diode+ fuse , schottky diode from PACK+ to Kit+ but none of them have worked.
As you can see from attachment PACK+ voltage reaches about 300V for approximately 10ns.
Unfortunately VDD pin of IC connected to PACK+ and the IC(bottom) has broken a few times when I was testing.
I would appreciate if you can give an idea.
Thanks.
 

Attachments

Thread Starter

ilginsarican

Joined Jul 13, 2017
106
Hello again,
After studies, I have realized that there was an electromagnetic interference from ballast.
There are both of radiated EMI and conducted EMI problem.
I used ferrite core for conducted EMI, and I wrapped the ballast with foil for radiated EMI.
The problem was partially resolved but not completely resolved.
I would be very happy if there were different suggestions.

Thanks.
 
Top