ESP8266-01 and Arduino UNO not working with logic level shifter

Thread Starter

zazas321

Joined Nov 29, 2015
473
Hey. I am working with ESPS and trying to program them with Arduino UNO with arduino software. I am able to write a program to ESP8266-01 without using any logic shifting - I connect RX to RX and TX to TX directly. When i ground the reset pin while reset the GPI0 i can write the program to ESP8266 but it does not seem to do what it is supposed to.

The code I have used:
/*
ESP8266 Blink by Simon Peter
Blink the blue LED on the ESP-01 module
This example code is in the public domain

The blue LED on the ESP-01 module is connected to GPIO1
(which is also the TXD pin; so we cannot use Serial.print() at the same time)

Note that this sketch uses LED_BUILTIN to find the pin with the internal LED
*/

void setup() {
pinMode(LED_BUILTIN, OUTPUT); // Initialize the LED_BUILTIN pin as an output
}

// the loop function runs over and over again forever
void loop() {
digitalWrite(LED_BUILTIN, LOW); // Turn the LED on (Note that LOW is the voltage level
// but actually the LED is on; this is because
// it is active low on the ESP-01)
delay(1000); // Wait for a second
digitalWrite(LED_BUILTIN, HIGH); // Turn the LED off by making the voltage HIGH
delay(2000); // Wait for two seconds (to demonstrate the active low LED)
}

This program should flash an inbuilt BLUE led, but is not doing anything. However the blue LED flashed rapidly when the ESP8266 is being programmed.


When i try to use logic level shifter that I have bought for the purpose the program the ESP8266-01 with arduino, is not working. I am just getting usual memory error:

warning: espcomm_sync failed
error: espcomm_open failed
error: espcomm_upload_mem failed
error: espcomm_upload_mem failed
 

Attachments

Top