Drone does not work

Thread Starter


Joined Jan 21, 2018
My Bellwether drone by (JJRC) does not takeoff. Battery is good. Yesterday, 3 props worked OK, fourth did not move. Now although the lights come on, it doessnot move. Transmitter/rcvr seem OK as lights on drone seem to acknowlege tranmitter signal. Any thoughts appreciated.


Joined Jan 15, 2015
Yesterday, 3 props worked OK, fourth did not move.
Well then I guess I would start by working backwards from the motor which did not work. Was there power to the motor as in the other three working motors? If yes then remove and replace faulty motor. If No then work backward. You have three working motors so note the signals paths backward from the working motors. This will tell you what you should see. You make no mention of what if any test, measurement and diagnostic tools you have at your disposal?



Joined Mar 13, 2020
Quick jump-in then back out: Test the inactive motor by moving its power plug to one of the other motor's output plugs. If changing the motor plug doesn't change the fact that the one motor doesn't run then you know the problem is in the motor. By switching motor leads you can verify the controller is actually trying to send a signal to the motor.

OK, jumping back out.