DRO readout not counting correctly

Discussion in 'Technical Repair' started by Model-a, Apr 8, 2018.

  1. Model-a

    Thread Starter Member

    Jun 16, 2009
    18
    2
    My Sargon dro on the x axis does sense a signal from the glass scale, but, numbers are amplified by a large amount and not uniform (not just a decimal point problem). I switched cables from x to y and it definitely is the readout and not the glass scale. Of course Sargon is out of business and I have no schematic. I bought this in 2005 and the numbers are red led style. I haven't looked inside yet, any suggestions?
     
  2. Model-a

    Thread Starter Member

    Jun 16, 2009
    18
    2
    I am enclosing a list of the ICs on the circuit board and a photo of the board. There isn't much else on the board except a crystal and 1 transistor. The ICs that have 2 on the board I switched them with no difference in my problem. Since I have no idea what is on the eprom I am stuck if that is the problem.
     
  3. JoeJester

    AAC Fanatic!

    Apr 26, 2005
    4,074
    1,776
  4. Model-a

    Thread Starter Member

    Jun 16, 2009
    18
    2
    Yes, they say send it in and we will evaluate it for a charge and that charge will apply to the repair cost if I choose to have them fix it. I thought I might try replacing the ICs that I can get and see where that gets me. what I hoped I might get from this forum is no it is probably the EPROM or microprocessor or yes one of the chips I can get could fix my problem.
    The Sargon site will also sell me a new readout with adapters to my glass scales connectors for $350 or so. Anyway, thanks for looking at my request.
    Allen
     
Loading...