ADP5070 sepic circuit sees overcurrent condition

Thread Starter

acheriti

Joined Apr 26, 2020
20
Hi guys,
I'M using a ADP5070 from analog device to generate a +8V and a -4V . The circuit for the -4V works fine. As for the +8V it does not.
The circuit used is a SEPIC topology. You can see the circuit schematic in the pictures linked(sepic.png).
The behavior I am observing is that the ADP5070's over current condition keeps getting trigged . I used an oscilloscope to probe at the indutctance's pins and what I see is that the circuit switches for a certain period of time and after that nothing happens for about 32ms (picture linked sw1.png). When reading about this in the datasheets it says that this timeout is due to an overcurrent condition in the switch node. (current_sense.pgn,current_sense2.pgn,reset_time.png)
Does anyone have an idea why I might have an over current condition? I've simulated my circuit before designing it and in simulation it worked just fine.
I've also tried to use the soft start of the circuit by adding a 100k resistor. Strangely my restart delay increased by 150ms while I was expecting a 20 ms increase(reset_time.png), and unfortunately it did not solve my problem (softstrt.pgn)..
Thanks for the help guys
 

Attachments

jeffl_2

Joined Sep 17, 2013
45
I haven't used that part or configuration, apparently the SEPIC design came from the ADIsimPower design program (or should have). I'm not familiar with that either and I don't know if it talks about the current rating of the inductors in the transformer, but it's every bit as important as if a single inductor were used. On page 19 of the ADP5070 data sheet it says "Ensure that the peak inductor current (the maximum input current plus half the inductor ripple current) is below the rated saturation current of the inductor." Have you done that? It's frequently hard to get that rating for a transformer but I suspect it's being exceeded in the device you're using.
 
Top