26VAC to 5VDC Power regulation circuit problem

Thread Starter

don3134

Joined May 30, 2018
4
I am attempting to isolate and fix a circuit board for the local adult school's horizontal bandsaw as a way of giving back to the community. I have attached a schematic that I created from tracing the PCB connections. The issue is that the 5V Buck Regulator output is at 8.5v instead of 5V and goes into a PIC. If anyone can help me with the circuit issue, I would greatly appreciate it. Below is the circuit with components and values. I do not know the
value of the inductor.

Thanks in advance for any help you can provide.
 

Thread Starter

don3134

Joined May 30, 2018
4
Bertus, Thank you for the response. The inductor in the circuit is an L38. I'm trying to understand why the voltage is not regulating to 5.0v, but instead it's outputting 8.5V. I've attached the circuit with the inductor information included. Any insights would be greatly appreciated.
 

Attachments

AlbertHall

Joined Jun 4, 2014
11,238
In the absence of any other suggestions, maybe the diode or the 4700uf is open circuit. I am not sure what the effect of that would be but apart from the LM2596 I can't see any other candidates.

Incidentally, I hope you got the value of at least one of the resistors wrong otherwise the PIC has about 20V on RC0.
 

Thread Starter

don3134

Joined May 30, 2018
4
In the absence of any other suggestions, maybe the diode or the 4700uf is open circuit. I am not sure what the effect of that would be but apart from the LM2596 I can't see any other candidates.

Incidentally, I hope you got the value of at least one of the resistors wrong otherwise the PIC has about 20V on RC0.

Albert,
Thanks! I will recheck that. I'm working from the original circuit board on this machine that was donated to the school. At one point it worked, but something has gone bad on the board.
 
Top