ESP-12 flashing problems

Discussion in 'Embedded Systems and Microcontrollers' started by Motanache, Oct 15, 2015.

  1. Motanache

    Thread Starter Member

    Mar 2, 2015
    70
    4
    I have ESP8266MOD:

    [​IMG]

    It was interfaced at computer.
    1.
    I use Don Kinzer esp_tool.exe, a command line program.

    The messages that it give are:
    Connecting.......connection established.
    Erasing 520192bytes.......
    ...............
    Writing block 2 o 508 at 0x000400
    Download file "bin.bin" failed (-9)


    2.NODEMCU programmer:
    Log:
    Begin find Esp8266.....
    and it remains so for long time
     
  2. be80be

    Senior Member

    Jul 5, 2008
    431
    57
    You do know you have to tie the pins like this
    GPIO0 -> LOW

    GPIO2 -> HIGH

    GPIO15 -> LOW
     
  3. Motanache

    Thread Starter Member

    Mar 2, 2015
    70
    4
    Yes, I did.

    I succeeded to put another firmware.
    I know this because the blue LED began to operate continuously.

    It did not further worked:

    I successfully installed iot.apk tablet app.

    I put IoT firmware on ESP-12.

    There was no connection made between the ESP-12 and tablet.
    Tablet sees no 'external' WiFi network.

    ESP-12 has GPIO0 ->Hi (V+3.3V) in this monet and and not receives At command.
    (It is stand alone)

    On my tablet look like the picture attached(not my picture).
     
  4. Motanache

    Thread Starter Member

    Mar 2, 2015
    70
    4
    On my tablet look like the picture attached(not my picture).
    write firmware starting with 0x0000 mem addr,

    DIO
    Crystal Freq. 26MHz (???) (chosen between 40MZ 26MHz 24MHz)

    SPI SPEED:40

    Flash SIZE 32 Mbit
     
    Last edited: Oct 18, 2015
  5. be80be

    Senior Member

    Jul 5, 2008
    431
    57
    If your esp has LUA on it there is no AT commands.
     
  6. Motanache

    Thread Starter Member

    Mar 2, 2015
    70
    4
    .I'm a beginner.

    Any project of this device is welcome.
    Any "Hello world" Program......
    Any LED that flashes program....

    I do not have Arduino,I have just PIC16F, PIC30F and just PICKIT2.
    And of course, USB->Rx,Tx


    <<If your esp has LUA on it there is no AT commands.>>
    I do not believe to be LUA firmware.
    I think hyperterminal not put entire line termination: line feed (LF) and carriage return (CR).

    Many projects are on the internet as open source.
    Not worked none of those tested.
    If you know a project that it work once you post please !!

    Would be and programming Micro Python, about that again I do not know
     
    ErnieM likes this.
  7. Motanache

    Thread Starter Member

    Mar 2, 2015
    70
    4
    After long searching......
    I learned that can be programmed with an Arduino software.
     
  8. RRITESH KAKKAR

    Senior Member

    Jun 29, 2010
    2,831
    89
    hello motoanche,
    Which of project is this?
     
    ErnieM likes this.
  9. Motanache

    Thread Starter Member

    Mar 2, 2015
    70
    4
    IoT.apk
    IoT firmware

    offered free from AI Thinker
    https://www.ai-thinker.com/
    uses Google Translate, so that you understand something there
     
  10. mcgyvr

    AAC Fanatic!

    Oct 15, 2009
    4,770
    970
  11. Motanache

    Thread Starter Member

    Mar 2, 2015
    70
    4
    I followed the steps to "Upload sketch".
    Since there has never worked.

    What we have shown in the first picture is ESp-12 or ESP-12E ?

    I seek only for a firmware (first) to 'match' an android application.

    I want to make the most simple remote control as a first step.
     
  12. be80be

    Senior Member

    Jul 5, 2008
    431
    57
    It don't matter if it's a ESP-12 or ESP-12E .
    What matters is are you going to flash with windows or linux.
    Are you going to use the Arduino ide or not.
    Are you going to use Lua or not.
    If you using the arduino ide you have to install needed files using.
    http://arduino.esp8266.com/stable/package_esp8266com_index.json
    add the above to your preference as shown in starthere pic.
    Then as shown in AddEsp pic add the libraries for ESP stuff.
    Then pick your board as the pickB pic shows.
    Then load your code and hook the esp to your computer the same way you do a arduino and it programs it.
    starthere.jpg AddEsp.jpg PickB.jpg upload.jpg
     
    Last edited: Oct 25, 2015
  13. Motanache

    Thread Starter Member

    Mar 2, 2015
    70
    4
    Thank you very much for your answer.
    Please understand that I am just a beginner.

    I put this firmware: nodemcu_float_0.9.6-dev_20150704.
    Worked writing firmware.

    I use Windows because cable USB-> Rx, Tx have only for driver foar Windows.
    I have also a version of Ubuntu.\

    As it looks in the above images for which thank you,
    I did:
    - I installed the Arduino IDE (unzipped)
    - I installed ESP8266 package
    - I selected Tools->Board-> ...(ESP-12)

    - When I select compilation last very long
    - downloading program to ESP8266 not work without any error ans.
    (at me does not work even nodemcu flasher)
    - Tools-> Serial monitor -> "AT" , Send with "LF and CR" line end.
    -> No answer from ESP8266.
    At this time appears the blue window from Windows.

    I have Windows XP SP2. Given all the other programs have worked: Proteus 8, MPlab,....

    Is there another possibility to compile program and download the ESP8266 with another software?
    I have software that can write in ESP8266 starting from any address.
     
    Last edited: Oct 26, 2015
  14. be80be

    Senior Member

    Jul 5, 2008
    431
    57
    nodemcu_float_0.9.6-dev_20150704 that doesn't have AT commands.
     
  15. Motanache

    Thread Starter Member

    Mar 2, 2015
    70
    4
  16. Motanache

    Thread Starter Member

    Mar 2, 2015
    70
    4
    I wrote this firmware: AT25-SDK112-512.bin

    Then GPIO0->1,
    Blue LED lights continuously now.

    Not respond to any command and blocks at serial communication.

    With Arduino IDE I got:
     
  17. be80be

    Senior Member

    Jul 5, 2008
    431
    57
  18. Motanache

    Thread Starter Member

    Mar 2, 2015
    70
    4
    I downloaded that file.

    I wrote the 'firmware' as follows:
    blank.bin 0x7E000
    boot.bin 0x00000
    user1.bin 0x01000

    Write worked ok.

    AT command unresponsive!

    -------------------------------------------------
    The pin remained:

    CH_PD -> HIGH
    GPIO2 -> HIGH
    GPIO15 -> LOW
    RESET-> NC (not connected)

    The only difference is:
    GPIO0 -> HIGH
    The pins are directly connected to power without resistors.
    Blue LED lights continuously.
    AT command unresponsive!
    ----------------------------------------------------------------------
    Another try:

    CH_PD -> HIGH
    GPIO2 -> NC
    GPIO15 -> NC
    RESET-> NC (not connected)
    GPIO0 -> NC

    Blue LED lights now OFF.
    AT command unresponsive!
     
  19. be80be

    Senior Member

    Jul 5, 2008
    431
    57
    [​IMG]
    like that pic
     
  20. be80be

    Senior Member

    Jul 5, 2008
    431
    57
    Try this there's a read me in the zip that tell how to flash what files where
     
Loading...