Weird jdm programer problem

Discussion in 'Embedded Systems and Microcontrollers' started by mamech, Apr 24, 2011.

  1. mamech

    Thread Starter Member

    Nov 3, 2010

    I have bought a JDM programmer several years ago, and I used it many times. Then I left it for some years, and now I need it to burn some code with it. The problem that the winpic initialize the programmer successfully, but it can not neither read, verify nor program the PIC !! The win pic behaves as if I am putting nothing in the JDM programmer !!

    I am using a computer with serial port in it.

    I do not know what is the source of error : (

    Can anyone help me ?
  2. nerdegutta


    Dec 15, 2009
    What type of JDM?

    Is the serialport configured as it was when you successfully programed PICs? In the computer BIOS.

    Probably a stupid one: Is the PIC inserted the right way?

    Have you tried more than on PIC?

    If there is some IC's on the JDM, could they have been destroyd by static electricity?

    Just some random thoughts... :)
  3. mamech

    Thread Starter Member

    Nov 3, 2010
    1-I do not not know what is the type of this JDM.
    2-I really do not remember if the serial was the same configuration in past or not. but 98% it was the same :)
    3-I tried one f1684a and f877. If I inserted the first wrongly, the second is 40 pins micro, so it does not have many positions to be mounted with :)
    4-I do not see any ics in this JDM, just punch of capacitors, transistors, resistors, indication led etc...

    When I try to verify the device using winpic it says "nothing in buffer". Is this info helpful ?