Voltage regulator help?

Discussion in 'The Projects Forum' started by markf5020, Mar 27, 2011.

  1. markf5020

    Thread Starter New Member

    Mar 27, 2011
    Hi everyone,

    I'm a 1st year student in an engineering technology program and recently learned about voltage regulators, and decided to build a circuit of my own, to function as a USB charger in my car, just for fun!

    I used an LM7805 typical regulator for 5v, a 330pf and 100pf pair of capacitors to filter. The circuit worked fine when I was testing it out, I was charging my cellphone for a while. But last night I installed it in my car, and it worked for a couple of minutes and then stopped working, I pulled it out and checked it over, and noticed the Vout was hovering around 10.5 to 11.0V when running off my 14V supply.

    I am stumped as to what is going on, did my cellphone draw too much current and fry the regulator?
  2. SgtWookie


    Jul 17, 2007
    It sounds like the ground terminal from the regulator is not making connection to ground. Without that connection, the output of the regulator will "float" to around 2v-3v less than the input voltage. The ground terminal normally has an output of somewhere around 5mA to 6mA during normal operation to establish the internal reference voltage. If there is no place for that current to go, the output voltage will rise.

    The caps are supposed to be 0.33uF on the input, and 0.1uF on the output, located as closely to the terminals as possible.
    0.33uF is 330nF, or 330,000pF.
    0.1uF is 100nF, or 100,000pF.
    Last edited: Mar 27, 2011
  3. markf5020

    Thread Starter New Member

    Mar 27, 2011
    Thanks Sgt! Your advice definitely sounds exactly like what is going on, and I know my soldering skills have much room for improvement so it would seem I did not create a good connection.
    I am using the 330 and 100 nF caps, unsure as to why I posted pf.

    Anyways, thanks again! I will re-solder the gnd connection tomorrow.