Upgrade MKII problem?

Discussion in 'Embedded Systems and Microcontrollers' started by Mathematics!, May 21, 2009.

  1. Mathematics!

    Thread Starter Senior Member

    Jul 21, 2008
    I accidentally hit the upgrade button in the AVR studios version 4.
    I didn't proceed with the upgrade I just canceled instead of hitting the final upgrade button. Know my programmer has a flashing orange/red light and a green light.

    I cann't program with it. It doesn't let me connect the device?
    I cann't get the orange and red to stop flashing?
    I have tried closing and reopening avr studio's but that didn't work.
    I have tried unplugging the usb from the programmer that didn't work either?

    My programmer is the one in this picture

    And the connections and everything have been check it was working right before I hit the upgrade button and I haven't moved or touched any of the wires or anything since the time it was working.
  2. hgmjr

    Retired Moderator

    Jan 28, 2005
    Go through the instructions for recovering your MKII from a corrupted upgrade as describe here on the ATMEL website.

    This should get you back on the right track.