Ultrasonic Range Finder Project

Thread Starter

lio2000

Joined Jun 1, 2011
6
hi
I'm trying to build an Ultrasonic Range Finder as my graduation project
I had some major setbacks for my main ideas for the project so for lack of time "since the deadline is near" I decided to use a ready model so I choose this model "since it is simple and straight forward "
http://jrzp.files.wordpress.com/2011/04/renesas_app_note_ultrasonic_range_finder.pdf

the reciver with the signal detector works fine
but the transmitter circuit refuse to work when i tried to simulate it using Multisim v11.0
it won't simulate "giving me an error without knowing where the error is"
the photo for my circuit is below
http://a.domaindlx.com/lio2000/Images/transmitter.JPG
if the pic didn't open keep refreshing

is everything right their?

I think it is in the resistors but can't but my finger where the problem is exactly..
I'm attaching the design file if someone using the programe

thanks for your time
 

Attachments

ErnieM

Joined Apr 24, 2011
7,992
Did you actually build this thing or are you just simulating it?

I imagine the error is connecting the bottom output to the scope return.

Don't do that.

Forget about the cap, connect one output to Scope A, the other to Scope B, and see that they are out of phase. If they are you're good.

(And while you're at it look hard at Q1 and Q2, they don't seem to be doing anything that a piece of wire can't.)

You do know you can buy these things complete, right? Just stick one onto your micro controller? I know the Basic Stamp people have some, and lots of other people do too.
 

Thread Starter

lio2000

Joined Jun 1, 2011
6
I'm trying to simulate it..didn't reach the building process

I did remove the cap. and the error still appears
=====================================================
Error Message From Simulation: doAnalyses: Timestep too small
Error Message From Simulation: tran simulation(s) canceled
=====================================================

and if I changed the connection points from Q1 &Q2 the outputs from the inverters will be 1 always...and I want them out of phase

I did re-simulate it using a program named "circuit wizard" and showed the current flow.. i saw all parts are working fine.. but the output from the circuit is 0

any more ideas??

the design of the circuit is in the pdf I added in the post.. i just need to verify the outputs before building my circuit on the test board
 

ErnieM

Joined Apr 24, 2011
7,992
=====================================================
Error Message From Simulation: doAnalyses: Timestep too small
Error Message From Simulation: tran simulation(s) canceled
=====================================================
Ummm, make the Timestep larger? I don't use that simulator. I don't like simulators in general, I prefer excel and a breadboard.


and if I changed the connection points from Q1 &Q2 the outputs from the inverters will be 1 always...and I want them out of phase
The inputs to Q1 & Q2 are out of phase. That's what makes the outputs out of phase. If I want a device with 2 out of phase inputs and 2 out of phase outputs I can build that with two pieces of wire.

In fact, I just noticed this is built with 5 discrete CMOS gates, 4 resistors, 2 transistors, and that cap. Toss em all but the cap and get a hex inverter. You even get a spare inverter for your trouble, and 8 less power supply connections to make.

Now don't get scared, but when I made an ultrasonic device controller I got my two out of phase signals from two pins off my micro and connected then direct to the transmitter. No IC, no cap, direct connection. Two pieces of wire period.

See if that sims.;)

You should know about the PING))) ultrasonic sensor. They used to have a schematic link there, I didn't find it today.
 

Thread Starter

lio2000

Joined Jun 1, 2011
6
sorry for the late reply:
here is what's going on now:
I switched from Multisim Simulator to circuit wizard
So the transmitter finally worked
BUT
the output is not to my liking...
first: I noticed that the trigger in 555-timer "logically" is set to Don't care condition -have no effect over the timer-

second: the variable resistor is not effecting of the output of the timer or the final output

third:The output as not stable -has no periodic cycles-[considering that the output in the attached file in practical will be the combination of both signals in the chart-

the receiver part is not bad
almost working
just trying to figure what the error "exp: overflow error" is means

I have a feeling it is all in the resistors but can't verify that for sure
any idea
both circuits are added along with the results
 

Attachments

Top