Treadmill motor - thumping noise from choke transformer

Discussion in 'The Projects Forum' started by josh1e, Jun 19, 2010.

  1. josh1e

    Thread Starter New Member

    Jun 18, 2010

    I have a Reebok RT1000 (RETL1600.1) treadmill,

    it was given to me faulty & I enjoy tinkering so am trying to fix it to use myself....

    when i turn it on, the console beeps ready. everything visually seems fine.

    then i push up on the digital speed control, the motor starts but there is some arc'ing from the bushes & a very large thumping sound coming from the choke transformer.

    the faster the motor spins the less frequent the thump, i did notice the thump happens each time the SCR TRIG led (location LD3) illuminates.

    I have the model with a power board (Euro 101 P/N 133275, Icon 1996. BF-P079010-000 Vendor# 1506) & seperate Motor control board (Icon MC-66 1000w).

    A bit of history on the unit & what i've tried so far....

    The treadmill came with faults which included uncalibrated speed (if & when it worked) motor sometimes came on when told, sometimes came on at power up & span regardless of console input, sometimes the console wouldn't illuminate / no readouts.

    So far i have read thoroughly the other posts on this forum regarding MC-60 repairs & a good google search, I checked against treadmill doctors troubleshooting & found a manual and hand written circuit diagram of the mc-60 (similar model)

    Following other people's experiences, I have replaced the 3x D8020L transistors (location D9, D? & D13) & 2x S8020L transistors (location Q6 & Q7) on the motor control board, although 12v LED (location LD1) wouldn't light, so i have replaced that & it now works. I also found the zener diode (location D11) was faulty so have now replaced that (after replacing the transistors) The two rubicon capacitors 250v 470uF I replaced too.

    I also replaced a fried diode on the power board (location D7) and the PWM led (location LD2)_and the Tach led (location LD4) which now both work properly.

    The 9vdc led used to work, but i forgot it didn't have a built in resistor, when i tested it for polarity, it blew. i have replaced it, but the led still won't illuminate, even with a new one. I have checked it isn't in the wrong way around....

    When i ran the treadmill when i first got it, there was no arc'ing inside the motor, nor was there any thumping sound, I tried gently filing down the bushes to ensure good connection, although this didn't make any difference. I wonder if it is either mis-matched components or something i've upset? To make things easier I have everything on a test bench at the moment and there is a good earth connection between all the components..

    could it be a fried transistor from running it with a knackered zener diode? I have replaced them, but didn't spot the diode before trying it... Could it be a fault of the 12v LED not being illuminated?

    I couldn't identify the value of the zener diode on the motor control board at location D11, so my local electronics dealer gave me what he thought was a good replacement, likewise for the diode at location D7 on the power board.

    I have a replacement opto isolating transistor, but couldn't find an exact match, the one the electronics dealer gave me didn't work when i tried it :(

    so now i'm stuck! anyone any ideas on what could be causing the transformer thump noise? or the arc'ing in the motor? or the 12v led not to work, even when it's replaced for a known good one?

    Please see photo's - thanks

  2. josh1e

    Thread Starter New Member

    Jun 18, 2010
    photo of power board with components i've replaced / were suspect...

  3. retched

    AAC Fanatic!

    Dec 5, 2009
    I would call an exorcist. ;)

    Have you looked on the solder side for solder bridges?

    I had repaired a treadmill with the 'Motor starts on power-up' problem.

    The cause was a solder bridge that shorted the 'start' control. So the signal jumped the transistor directly starting the running belt at power up.

    About 30 seconds with a rotary tool to cut the bridge, done.

    You may have more problems. Sometimes, with mass produced boards of ole' quality control wasn't so great and the wave soldering pool was sometimes overfilled, or the flux hopper would run dry leading to cold solder joints and/or bridges.
  4. josh1e

    Thread Starter New Member

    Jun 18, 2010
    hi retched,

    thanks for the advice.

    I have solved the thumping problem, no not poltergiests :) the zener diode the local shop suggested would be a good replacement turned out to be the issue... replaced it with the original and problem solved......

    so, at the moment, i am trying to figure out why i still cannot get the 12v light to illuminate.. the resistor @ R13 measures 201.4ohms in circuit, it's meant to be 201+-5%

    the diode @ D8 which supplies the resistor i replaced with a 1n4007, although since putting it into the pcb, it now shows 0 ohms in 1 direction & 1.633Mohms in the other...

    next step is to test the onboard transformer output, i'm sure that's okay though as the motor control board IS getting 12vdc (it's 12vdc light is lit)

    i'll post some resistor & diode readings shortly, someone may be able to tell me if they think 1 is faulty, it may also serve someone else in the future for reference... there isn't alot on a google search about trying to component level repair these boards...

  5. josh1e

    Thread Starter New Member

    Jun 18, 2010
    Okay, to check what's still faulty on the power control board (euro 101) Ive taken readings with the components still in circuit with my digital multi meter.

    The power board was completely unplugged with no power running through it.

    The values are resistor location, value from the bands on the resistor, and actual reading taken. The only one which seems off is the massive white resistor which supplies the correct power to the 230V active LED.
  6. JackHerer

    New Member

    Sep 3, 2010
    Hello Josh, and everyone else (maybe),

    I realise that this thread ended in June and that i may be talking to myself but i could do with a bit of badly-needed advice since you know more about the MC-66 than i do. Anyway, here goes, I have a MC-66 controller exactly the same as the one in the pic, and a 230VDC motor. What i've been trying to find out is how to connect them together with a 10K pot to control the speed, and a choke (inductor coil) that may or may not be required, bought from ebay.

    In your pic, you also have a power board - is this required in my case, or is it soley to provide lower dc voltage to the console?

    Also, the small, black, 3-pin HD1 connector on the MC-66 is connected to the power board - could I connect a 3-pin 10K pot to that connector for speed control, since I thought the letters "LWH" written next to the connector meant Low-Wiper-High on a pot?

    Any advice is most appreciated.