Treadmill Motor Board DCMD67 Newbie needs help

Thread Starter


Joined Oct 4, 2012

I enjoy tinkering with basic electronics and have done basic component "swapovers" - faulty caps etc in previous projects. This one has me a bit stumped and I'm not 100% sure where to start and would like some guidance, or maybe even input from those that know this circuit.

The treadmill is a Dunlop NK9000, and was given to me by a relative after I was advised the fuse kept blowing - in the end the relative used 10A fuse wire :rolleyes: instead of constantly replacing fuses :eek: - not sure what the original value of this Fuse F1 should have been - hope someone may know or be able to help out.

Fault is that the treadmill powers up, when you press start the belt does not move, however belt and motor will move well when powered off cordless drill battery. Assuming fault is on board because of description of constant fuses blown, something possibly shorted.

Visual inspection of caps seem fine, I've tested the four diodes in both Bridge Rectifiers which seem ok, all the diodes on the board seem to conduct in one direction as they should except for D34 which conducts in both directions (next to large cap) - believe this is Zener diode and not sure if this is normal or if some other device is causing that reading.

Of the four "Three pin" transistor looking components the two at the bottom of the image U11 and U18 are labelled UFF100-04 and K15N60 respectively. The two close to each other near the fuse Q2, Q3 are both identical STP6A60. Not sure how to test any of these components yet.

Im not sure what I should be testing next - transformer, resistors, small SMD components. Is there a logical order I should test these in?

I hope someone can help me. Let me know if further pictures may help. I've tried to attach a large enough hi res picture.

Sorry for the essay :)



Joined Sep 9, 2010
Q11 in the lower right corner. It looks a bit odd, like maybe it's not connected well to the heat sink anymore. Could just be the picture. Can we get a better look at it?

Having a schematic would boost your odds of fixing this. Be relentless with searching.

One of the power transistors may have shorted. It can be misleading to test them on the board. How are you at desoldering? Do yo have a meter with a diode test function?


Joined Jun 22, 2012
Looks like its Triac Q2/Q3 STP6A60 ,and opto coupler controlled, so your looking to see if the optos are getting a dc supply.
What are the markings on the IC's?

Thread Starter


Joined Oct 4, 2012
Thanks wayneh, U11 in the bottom right is a UFF100-04. I had unscrewed each of the devices along the bottom in order to remove from heatsink and check underside of board. Hadn't aligned it when I took the photo, but will get better photo's up tonight. I looked the part up and did test this last night, internally it seems to be two diodes with a common cathode pin. This is testing correctly as for diodes.

I've been unable to locate a schematic, but still looking. I'll give desoldering a go and I do hve a diode test function.

Next to the U11 there is U12, this is a K15N60. I'm not 100% sure if I've tested it correctly - used a youtube tutorial. I believe the pins are in order from left to right Gate, Collector then Emitter. -'ve to E, +'ve to C, then touched G with +'ve lead and back to C. Watching the tutorial this should then show a figure on the multimeter, on mine when back on C it shows O.L. (When I touch the gate it shows a figure of about 1.3V)

Will desolder, test again and report back.

Is it normal for a diode D34 (Zener) to show .660 one way and 1.1 tested the other way in diode test mode?

Thread Starter


Joined Oct 4, 2012
thanks dodgydave,

I've located the Triac's you described, not sure how to test these or what "opto's" are. Do these have a number on the board to easily locate?

Thread Starter


Joined Oct 4, 2012
Did a bit of reading and learning and I think I've found the "optos". U16, U17 - MOC3063's and found the datasheet online :

Took these out of circuit and tested.

Strangely in the datasheet it looks like pin 3 and pin 5 aren't connected. (If I'm reading that right).

Tested the internal Diode on both, and get 1 way 1.0V, other way O.L.

Not sure how to test the connection between pins 4 and 6. Diode test returns O.L on both no matter which way the pins are. Interestingly on U16 I get a diode test returning 3.0V on pins 5,6 - this doesn't happen on U17. - I though pin 5 isn't connected - and the board has no trace on either side to pin 5 on both chips. - What the...Is one of these faulty?


Joined Dec 28, 2011
If you have more than one multimeter you may be able to test the output side of the optos. connect one multimeter across the pins 4 & 6 and set it to a resistance setting. then have the other meter in a diode check and connect the red lead to pin 1 and the black lead to pin 2. The resistance should change when you activate the internal LED. This is a really basic test and doesn't test the full functionality of the opto, but should give a "go/no-go" test.

From what I read on the datasheet pin 5 should not be connected to anything. The one you have that is showing 3.0V on pins 5 & 6 is probably bad.

Thread Starter


Joined Oct 4, 2012
I've now replaced the IGBT (U12), which didn't test right out of circuit with equivalent.

Have also replaced the opto's U16/U17 - these seem to be a part of the incline function circuit.

Put board back in the treadmill and motor still wont turn. - Interestingly I tried the incline, which I hadn't tested before - this is working. And the screen/controls are working on the top of the treadmill as normal.

Any other ideas on areas to test on this board?

Thread Starter


Joined Oct 4, 2012
Just put a multimeter on the motor + and - terminals on the board and got 1.1v at rest.

Hit start on the treadmill. The voltage stayed at 1.1v.

Have tested the relay and can hear a definite click when this engages.


Joined Oct 22, 2012
Jeff , I repaired so treadmill and look firstly U18- often died (caput :) , then look U9 - it's optodriver (2 and 3 are IN , 6 and 7 are OUT) . 5 & 8 must have about 15V . Here can measure with oscilloscope - F ~16kG WIM . signal arrive from chip ( top right corner ) and pls send foto MB when you try start , ecpecially red LED D2 .


Joined Sep 21, 2012


Joined May 5, 2013
Hi Jeff have you had any luck with this board. our treadmill uses this board but we don't have an incline function on it. The treadmill starts and cuts out and the red led is on constantly. We need help locating a diagram for the board. Can you offer any help.


Joined Apr 2, 2009
I have this control board. It's when I start the treadmill it's motor rotating fast and home breaker turn off. Already changed the motor also but still same problem
Start a new thread.
As for your problem your driver may be short. The Big transistor type thingy. Could be MOSFET or an IGBT